summaryrefslogtreecommitdiff
path: root/community/python-debugpy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/python-debugpy/PKGBUILD')
-rw-r--r--community/python-debugpy/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/python-debugpy/PKGBUILD b/community/python-debugpy/PKGBUILD
new file mode 100644
index 00000000..f3266163
--- /dev/null
+++ b/community/python-debugpy/PKGBUILD
@@ -0,0 +1,11 @@
+# patch 64-bit mode compilation to 32-bit mode (and naming of
+# resulting library)
+# why we would not just ommit the mode and omit the naming in
+# the library is beyond me..
+eval "$(
+ declare -f build | \
+ sed '
+ s/-m64/-m32/g
+ s/attach_linux_amd64.so/attach_linux_i686.so/
+ '
+)"