summaryrefslogtreecommitdiff
path: root/community/python-build/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/python-build/PKGBUILD')
-rw-r--r--community/python-build/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/community/python-build/PKGBUILD b/community/python-build/PKGBUILD
new file mode 100644
index 00000000..7b473826
--- /dev/null
+++ b/community/python-build/PKGBUILD
@@ -0,0 +1,17 @@
+# disable documentation (needs sphinx, sphinx-furo)
+# python-sphinx-furo needs npm, which is broken on archlinux32
+# most likely since years..
+makedepends=(${makedepends[@]//python-sphinx-furo/})
+makedepends=(${makedepends[@]//python-sphinx-argparse-cli/})
+makedepends=(${makedepends[@]//python-sphinx-autodoc-typehints/})
+makedepends=(${makedepends[@]//python-sphinx/})
+eval "$(
+ declare -f build | \
+ sed '
+ /.*sphinx-build.*/d
+ '
+ declare -f package | \
+ sed '
+ /.*\/share\/doc.*/d
+ '
+)"