summaryrefslogtreecommitdiff
path: root/community/nodejs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nodejs/PKGBUILD')
-rw-r--r--community/nodejs/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/community/nodejs/PKGBUILD b/community/nodejs/PKGBUILD
index 78f686cc..efbf8000 100644
--- a/community/nodejs/PKGBUILD
+++ b/community/nodejs/PKGBUILD
@@ -5,3 +5,13 @@ eval "$(
s|./configure|./configure --dest-cpu ia32|g
'
)"
+
+# linker runs out of memory on 32-bit
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i LDFLAGS+=" -Wl,--no-keep-memory"
+ 3 i CFLAGS+=" -g1"
+ 3 i CXXFLAGS+=" -g1"
+ '
+)"