summaryrefslogtreecommitdiff
path: root/community/linux-tools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/linux-tools/PKGBUILD')
-rw-r--r--community/linux-tools/PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/community/linux-tools/PKGBUILD b/community/linux-tools/PKGBUILD
index 9a71c096..acbe071a 100644
--- a/community/linux-tools/PKGBUILD
+++ b/community/linux-tools/PKGBUILD
@@ -2,10 +2,12 @@
for ((i=0; i<${#source[@]}; i++)); do
infos=$(
printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
+ sed '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ t
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ t
+ d
'
)
if [ -n "${infos}" ]; then