summaryrefslogtreecommitdiff
path: root/community/libavif/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libavif/PKGBUILD')
-rw-r--r--community/libavif/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/community/libavif/PKGBUILD b/community/libavif/PKGBUILD
new file mode 100644
index 00000000..10c53c42
--- /dev/null
+++ b/community/libavif/PKGBUILD
@@ -0,0 +1,20 @@
+# svt-av1 is 64-bit only
+depends=(${depends[@]//svt-av1/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DAVIF_CODEC_SVT=ON/-DAVIF_CODEC_SVT=OFF/
+ '
+)"
+
+# on i486 we ignore rav1e for now (needs rust)
+if [ "$CARCH" = 'i486' ]; then
+ depends=(${depends[@]//rav1e/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-DAVIF_CODEC_RAV1E=ON/-DAVIF_CODEC_RAV1E=OFF/
+ '
+ )"
+fi
+