summaryrefslogtreecommitdiff
path: root/community/ispc/ispc-1.16.1-host-amd64.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/ispc/ispc-1.16.1-host-amd64.patch')
-rw-r--r--community/ispc/ispc-1.16.1-host-amd64.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/ispc/ispc-1.16.1-host-amd64.patch b/community/ispc/ispc-1.16.1-host-amd64.patch
new file mode 100644
index 00000000..78ef5f20
--- /dev/null
+++ b/community/ispc/ispc-1.16.1-host-amd64.patch
@@ -0,0 +1,16 @@
+diff -rauN ispc-1.16.1/CMakeLists.txt ispc-1.16.1-host-amd64-patch/CMakeLists.txt
+--- ispc-1.16.1/CMakeLists.txt 2021-07-16 01:04:31.000000000 +0200
++++ ispc-1.16.1-host-amd64-patch/CMakeLists.txt 2022-04-07 08:57:32.100539305 +0200
+@@ -45,9 +45,9 @@
+ project(${PROJECT_NAME})
+
+ set(X86_HOST FALSE)
+-if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "AMD64|86")
+- set(X86_HOST TRUE)
+-endif()
++#if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "AMD64|86")
++# set(X86_HOST TRUE)
++#endif()
+
+ option(X86_ENABLED "Enable x86 support" ${X86_HOST})
+ option(ARM_ENABLED "Enable ARM support" ON)