summaryrefslogtreecommitdiff
path: root/community/ispc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ispc/PKGBUILD')
-rw-r--r--community/ispc/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/ispc/PKGBUILD b/community/ispc/PKGBUILD
new file mode 100644
index 00000000..ead7793e
--- /dev/null
+++ b/community/ispc/PKGBUILD
@@ -0,0 +1,41 @@
+# disable GENX
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DGENX_ENABLED=ON/-DGENX_ENABLED=OFF/
+ '
+)"
+
+# don't assume to be on a 64-bit Intel host and draw in gnu64 headers everywhere
+source+=('ispc-1.16.1-host-amd64.patch')
+sha256sums+=('7a4a631ad178b13f9ab68e6aec94469e30a4b9dec48d40f732a701b4ed4d5c1f')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname-$pkgver" \
+ patch -Np1 -i "$srcdir/ispc-1.16.1-host-amd64.patch"
+ '
+)"
+
+# ignore test results, GENX tests failing obviously
+eval "$(
+ declare -f build | \
+ sed '
+ s/\(make.*check-all\)/\1 || true/
+ '
+)"
+
+# packaging issue now as we are not building everything
+eval "$(
+ declare -f package | \
+ sed '
+ /rm.*build/d
+ /rm.*libispcrt_static.a/d
+ '
+)"
+
+# tests don't build when disabling GENX
+unset check