summaryrefslogtreecommitdiff
path: root/community/grpc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/grpc/PKGBUILD')
-rw-r--r--community/grpc/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/grpc/PKGBUILD b/community/grpc/PKGBUILD
new file mode 100644
index 00000000..05b3ada2
--- /dev/null
+++ b/community/grpc/PKGBUILD
@@ -0,0 +1,12 @@
+# -latomic on i486
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/cmake /cmake -DCMAKE_CXX_STANDARD_LIBRARIES=-latomic /
+ '
+ )"
+fi
+
+# Python tests failing due to LDFLAGS stuff, disabled for now
+unset check