summaryrefslogtreecommitdiff
path: root/community/ghc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ghc/PKGBUILD')
-rw-r--r--community/ghc/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/ghc/PKGBUILD b/community/ghc/PKGBUILD
new file mode 100644
index 00000000..e1aa6b7f
--- /dev/null
+++ b/community/ghc/PKGBUILD
@@ -0,0 +1,11 @@
+# bootstrapping from binary version (when ghc-static is broken)
+makedepends=(${makedepends[@]//ghc-static/})
+makedepends_i486+=(ghc90-bin libffi33)
+makedepends_i686+=("${makedepends_i486[@]}")
+makedepends_pentium4=("${makedepends_i686[@]}")
+eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|GHC=/usr/bin/ghc-9.0 ./configure|
+ '
+)"