summaryrefslogtreecommitdiff
path: root/community/gdal/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gdal/PKGBUILD')
-rw-r--r--community/gdal/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/community/gdal/PKGBUILD b/community/gdal/PKGBUILD
index 6aa81b69..f2c3ce89 100644
--- a/community/gdal/PKGBUILD
+++ b/community/gdal/PKGBUILD
@@ -1,3 +1,21 @@
+# enable SSE/SSE2 where appripriate
+if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure |./configure --with-sse=no --with-sse3-no --with-avx=no |
+ '
+ )"
+fi
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure |./configure --with-sse=yes --with-ssse3-no --with-avx=no |
+ '
+ )"
+fi
+
# no mariadb yet on i486
if [ "${CARCH}" = "i486" ]; then
depends=(${depends[@]//mariadb-libs/})