summaryrefslogtreecommitdiff
path: root/community/gdal/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gdal/PKGBUILD')
-rw-r--r--community/gdal/PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/community/gdal/PKGBUILD b/community/gdal/PKGBUILD
index f2c3ce89..8a896f4e 100644
--- a/community/gdal/PKGBUILD
+++ b/community/gdal/PKGBUILD
@@ -3,7 +3,7 @@ if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
eval "$(
declare -f build | \
sed '
- s|./configure |./configure --with-sse=no --with-sse3-no --with-avx=no |
+ s|./configure |./configure --with-sse=no --with-ssse3=no --with-avx=no |
'
)"
fi
@@ -11,18 +11,25 @@ if [ "${CARCH}" = "pentium4" ]; then
eval "$(
declare -f build | \
sed '
- s|./configure |./configure --with-sse=yes --with-ssse3-no --with-avx=no |
+ s|./configure |./configure --with-sse=yes --with-ssse3=no --with-avx=no |
'
)"
fi
-# no mariadb yet on i486
-if [ "${CARCH}" = "i486" ]; then
- depends=(${depends[@]//mariadb-libs/})
+# i486 has a stack smash when building the Python bindings (see FS32#188)
+if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- s/--with-mysql/--without-mysql/
+ /swig\/python/d
+ /python setup.py build/d
+ '
+ )"
+ eval "$(
+ declare -f package_python-gdal | \
+ sed '
+ 3 i if false; then
+ $ i fi
'
)"
fi