summaryrefslogtreecommitdiff
path: root/community/exa
diff options
context:
space:
mode:
Diffstat (limited to 'community/exa')
-rw-r--r--community/exa/PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index 1de368f8..f0d6c232 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -3,7 +3,13 @@
source+=('exa-ascii-deprecated.patch')
md5sums+=('ce36630a183f5d5be9f1a334bdf8a7cc')
-prepare() {
- cd "$pkgname"
- patch -Np1 -i ../exa-ascii-deprecated.patch
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname" \
+ patch -Np1 -i ../exa-ascii-deprecated.patch
+ '
+)"