summaryrefslogtreecommitdiff
path: root/community/exa/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/exa/PKGBUILD')
-rw-r--r--community/exa/PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index 81065c10..914a7177 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -1,6 +1,3 @@
-# rust currenly broken, is based on LLVM 11
-makedepends+=(llvm11)
-
# pandoc is mainly broken currently (FS32#180)
makedepends=(${makedepends[@]//pandoc/})
eval "$(
@@ -16,3 +13,13 @@ eval "$(
/exa_colors.5/d
'
)"
+
+# CARCH pentium4 makes compilation fail
+if [ "$CARCH" = 'pentium4' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/--target "$CARCH-unknown-linux-gnu"/--target "i686-unknown-linux-gnu"/
+ '
+ )"
+fi