summaryrefslogtreecommitdiff
path: root/community/exa/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/exa/PKGBUILD')
-rw-r--r--community/exa/PKGBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index f0d6c232..914a7177 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -1,15 +1,25 @@
-# fixed in git upstream
-
-source+=('exa-ascii-deprecated.patch')
-md5sums+=('ce36630a183f5d5be9f1a334bdf8a7cc')
-
+# pandoc is mainly broken currently (FS32#180)
+makedepends=(${makedepends[@]//pandoc/})
eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/$pkgname" \
- patch -Np1 -i ../exa-ascii-deprecated.patch
- '
+ declare -f build | \
+ sed '
+ s/pandoc/#pandoc/
+ '
)"
+eval "$(
+ declare -f package | \
+ sed '
+ /exa.1/d
+ /exa_colors.5/d
+ '
+)"
+
+# CARCH pentium4 makes compilation fail
+if [ "$CARCH" = 'pentium4' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/--target "$CARCH-unknown-linux-gnu"/--target "i686-unknown-linux-gnu"/
+ '
+ )"
+fi