summaryrefslogtreecommitdiff
path: root/community/embree/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/embree/PKGBUILD')
-rw-r--r--community/embree/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/community/embree/PKGBUILD b/community/embree/PKGBUILD
new file mode 100644
index 00000000..8d2043c8
--- /dev/null
+++ b/community/embree/PKGBUILD
@@ -0,0 +1,17 @@
+# avoid breakage in newer CPU ISAs, supporting SSE2 should be enough for
+# 32-bit platforms
+eval "$(
+ declare -f build | \
+ sed '
+ /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE2"/
+ '
+)"
+
+# some 32-bit fixes around intrinsics where applied to WIN32 only,
+# applying a counter-patch here
+source+=('embree-3.2.0-intrinsic.patch')
+sha256sums+=('7d5e44a034b02e14d7d37cd038d8c279d13d66b54a449c09e0687458f117723f')
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir/embree-3.2.0-intrinsic.patch"
+}