summaryrefslogtreecommitdiff
path: root/community/blender/no-sse2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/blender/no-sse2.patch')
-rw-r--r--community/blender/no-sse2.patch24
1 files changed, 11 insertions, 13 deletions
diff --git a/community/blender/no-sse2.patch b/community/blender/no-sse2.patch
index 082a566c..a32f7c64 100644
--- a/community/blender/no-sse2.patch
+++ b/community/blender/no-sse2.patch
@@ -1,14 +1,12 @@
-diff -rauN blender-vanilla/intern/cycles/bvh/bvh_embree.cpp blender-no-sse2-patch/intern/cycles/bvh/bvh_embree.cpp
---- blender-vanilla/intern/cycles/bvh/bvh_embree.cpp 2021-04-30 11:51:03.234550251 +0200
-+++ blender-no-sse2-patch/intern/cycles/bvh/bvh_embree.cpp 2021-04-30 11:52:15.691582206 +0200
-@@ -306,8 +306,10 @@
- rtc_device(NULL),
- build_quality(RTC_BUILD_QUALITY_REFIT)
- {
-+#if defined(__x86_64__) || defined(_M_X64)
- _MM_SET_FLUSH_ZERO_MODE(_MM_FLUSH_ZERO_ON);
- _MM_SET_DENORMALS_ZERO_MODE(_MM_DENORMALS_ZERO_ON);
-+#endif
- }
+diff -rauN blender-vanilla/CMakeLists.txt blender-no-sse2-patch/CMakeLists.txt
+--- blender-vanilla/CMakeLists.txt 2022-04-07 16:36:48.842414275 +0200
++++ blender-no-sse2-patch/CMakeLists.txt 2022-04-07 16:37:12.012470531 +0200
+@@ -981,7 +981,7 @@
+ # Test SIMD support, before platform includes to determine if sse2neon is needed.
+ if(WITH_CPU_SIMD)
+ set(COMPILER_SSE_FLAG)
+- set(COMPILER_SSE2_FLAG)
++# set(COMPILER_SSE2_FLAG)
- BVHEmbree::~BVHEmbree()
+ # Test Neon first since macOS Arm can compile and run x86-64 SSE binaries.
+ TEST_NEON_SUPPORT()