summaryrefslogtreecommitdiff
path: root/community/blender/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/blender/PKGBUILD')
-rw-r--r--community/blender/PKGBUILD28
1 files changed, 25 insertions, 3 deletions
diff --git a/community/blender/PKGBUILD b/community/blender/PKGBUILD
index 3dfd39ca..03a1eeb7 100644
--- a/community/blender/PKGBUILD
+++ b/community/blender/PKGBUILD
@@ -11,13 +11,13 @@ eval "$(
/^\s*cmake / s/;$/ -DWITH_CYCLES_CUDA_BINARIES=OFF -DWITH_CYCLES_DEVICE_CUDA=OFF -DWITH_RAYOPTIMIZATION=OFF;/
'
)"
-source_i686+=('arm-no-sse2.patch')
-sha512sums_i686+=('13890f9cd11ca20bcb6f12206c990e25c0d08699feab0fca37607d847d2aebd2d2f423023986e120eaaeb0beca9a440a4d42007dcac2054fe6cdaf745de43402')
+source_i686+=('no-sse2.patch')
+sha512sums_i686+=('87da2bedb90af6dee559ef9d1eb83262ba75fb412aba83dcb2b88fe9c0740ff75ad336331033fec7a14ad6ecc3dd70f8f4742f147594e8dc530197dd51922c01')
if [ "${CARCH}" = 'i686' ]; then
eval "$(
declare -f prepare \
| sed '
- $ i patch -Np1 -i "$srcdir"/arm-no-sse2.patch
+ $ i patch -Np1 -i "$srcdir"/no-sse2.patch
'
)"
fi
@@ -30,3 +30,25 @@ eval "$(
/^\s*cmake / s/;$/ -DWITH_CYCLES_DEVICE_OPTIX=OFF/
'
)"
+
+# FS32#182: opensubdiv/openexr/openvdb currently fails to rebuild
+depends=(
+ ${depends[@]/opensubdiv/}
+)
+depends=(
+ ${depends[@]/openexr/}
+)
+depends=(
+ ${depends[@]/openvdb/}
+)
+
+# float_t is a long double on 32-bit, but it's a primitive in all cases anyway
+# (seems to be in a part of the blendkernel on i686 only..)
+source+=('blender-idprop_create-static-assert-float.patch')
+sha512sums+=('36b98ec7e53402909a9e531c30b444b1afc22cc597c5bb3393c73862929dcc6275b00a53de6171a81af3c8804d233359d2e797886d0b776e7a9b29b23ce24e3b')
+eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -Np1 -i "$srcdir"/blender-idprop_create-static-assert-float.patch
+ '
+)"