summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
Diffstat (limited to 'build-support')
-rw-r--r--build-support/disabled/mesa/mesa177
-rw-r--r--build-support/disabled/rust140/PKGBUILD (renamed from build-support/rust140/PKGBUILD)0
-rw-r--r--build-support/disabled/rust140/config.toml.patch (renamed from build-support/rust140/config.toml.patch)0
-rwxr-xr-xbuild-support/disabled/rust140/watcher.sh (renamed from build-support/rust140/watcher.sh)0
-rw-r--r--build-support/disabled/rust141/PKGBUILD (renamed from build-support/rust141/PKGBUILD)0
-rw-r--r--build-support/disabled/rust141/config.toml.patch (renamed from build-support/rust141/config.toml.patch)0
-rw-r--r--build-support/disabled/rust141/rustc-1.41.0-src-typenum-U1024.patch (renamed from build-support/rust141/rustc-1.41.0-src-typenum-U1024.patch)0
-rw-r--r--build-support/disabled/rust148/PKGBUILD (renamed from build-support/rust148/PKGBUILD)0
-rw-r--r--build-support/disabled/rust148/config.toml.patch (renamed from build-support/rust148/config.toml.patch)0
-rw-r--r--build-support/disabled/rust157-bin/PKGBUILD (renamed from build-support/rust157-bin/PKGBUILD)0
-rw-r--r--build-support/disabled/rust159-bin/PKGBUILD37
-rw-r--r--build-support/libsigc++-docs-dummy/PKGBUILD2
12 files changed, 215 insertions, 1 deletions
diff --git a/build-support/disabled/mesa/mesa b/build-support/disabled/mesa/mesa
new file mode 100644
index 00000000..81de2061
--- /dev/null
+++ b/build-support/disabled/mesa/mesa
@@ -0,0 +1,177 @@
+# disable openswf as it requires AVX, makes no sense with old CPUs
+# disable every new software rasterizer and take the old ones
+# see also FS32#39
+eval "$(
+ declare -f build | \
+ sed '
+ /arch-meson/s/\(gallium-drivers=.*\),swrast,swr/\1,swrast/
+ /arch-meson/s/\(-D swr-arches=\)avx,avx2/\1/
+ '
+ declare -f package_mesa | \
+ sed '
+ s@_install fakeinstall/usr/lib/libswrAVX.*@#\0@g
+ '
+)"
+
+# See https://bugs.freedesktop.org/show_bug.cgi?id=93089
+# do not build/package vulkan on i486
+# do not build i915,i965 on i486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-D gallium-omx=bellagio //
+ s/-D gallium-opencl=\S\+ //
+ s/-D osmesa=true /-D osmesa=false /
+ s/\(-D gallium-\S\+=\)enabled /\1disabled /g
+ s/\(-D gallium-nine=\)true /\1false /g
+ s/\(-D vulkan-drivers=\)\S\+ /\1 /
+ s/\(-D dri-drivers=\(\S\+,\)\?\)i915,/\1/
+ s/\(-D dri-drivers=\(\S\+,\)\?\)i965,/\1/
+ '
+ declare -f package_mesa | \
+ sed '
+ \,rm .*/vulkan;,d
+ \,bellagio,d
+ \,fakeinstall/usr/lib/d3d,d
+ \,fakeinstall/usr/lib/libOSMesa\.so\*,d
+ \,fakeinstall/usr/lib/libxatracker\.so\*,d
+ '
+ )"
+else
+ eval "$(
+ declare -f package_vulkan-intel package_vulkan-radeon package_opencl-mesa package_libva-mesa-driver package_mesa-vdpau | \
+ sed '
+ /^\s*{\s*$/ a arch=('"$(
+ printf '%s\n' "${arch[@]}" | \
+ grep -vxF 'i486' | \
+ tr '\n' ' '
+ )"')
+ '
+ )"
+fi
+
+# break cycle with conflicting installation files between mesa and libglvnd
+# (indirect dependency via libva)
+# i486-specific
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f package_mesa | \
+ sed '
+ $ i rm -rf $pkgdir/usr/include/EGL/egl.h \
+ rm -rf $pkgdir/usr/include/EGL/eglext.h \
+ rm -rf $pkgdir/usr/include/EGL/eglplatform.h \
+ rm -rf $pkgdir/usr/include/GL/gl.h \
+ rm -rf $pkgdir/usr/include/GL/glcorearb.h \
+ rm -rf $pkgdir/usr/include/GL/glext.h \
+ rm -rf $pkgdir/usr/include/GL/glx.h \
+ rm -rf $pkgdir/usr/include/GL/glxext.h \
+ rm -rf $pkgdir/usr/include/GLES2/gl2.h \
+ rm -rf $pkgdir/usr/include/GLES2/gl2ext.h \
+ rm -rf $pkgdir/usr/include/GLES2/gl2platform.h \
+ rm -rf $pkgdir/usr/include/GLES3/gl3.h \
+ rm -rf $pkgdir/usr/include/GLES3/gl31.h \
+ rm -rf $pkgdir/usr/include/GLES3/gl32.h \
+ rm -rf $pkgdir/usr/include/GLES3/gl3ext.h \
+ rm -rf $pkgdir/usr/include/GLES3/gl3platform.h \
+ rm -rf $pkgdir/usr/include/KHR/khrplatform.h \
+ rm -rf $pkgdir/usr/lib/pkgconfig/egl.pc \
+ rm -rf $pkgdir/usr/lib/pkgconfig/gl.pc \
+ rm -rf $pkgdir/usr/lib/pkgconfig/glesv2.pc
+ '
+ declare -f package_vulkan-mesa-layers | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ declare -f package_vulkan-swrast | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ declare -f package_vulkan-intel | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ declare -f package_vulkan-radeon | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ declare -f package_opencl-mesa | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ declare -f package_libva-mesa-driver | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ declare -f package_libva-mesa-vdpau | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ declare -f package_mesa-vdpau | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ )
+ "
+fi
+
+# add libdrm and libxshmfence explocitily for now, as deep down in th
+# dependency tree as reasonable instead of patching all packages failing above
+if [ "$CARCH" = 'i486' ]; then
+ depends+=(libdrm)
+ depends+=(libxshmfence)
+ depends+=(wayland)
+fi
+
+# defaults changed to SSE2 enabled by default, disable it
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Dsse2=false /
+ '
+ )"
+fi
+
+# LTO on i486 results in out-of-memory
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-D b_lto=true/-D b_lto=false/
+ '
+ )"
+fi
+
+# libclc needs spirv-llvm-translator which throws heavily errors on 32-bit
+# LLVM_SPIRV :: DebugInfo/X86/dbg-declare-alloca.ll
+# LLVM_SPIRV :: DebugInfo/X86/dbg-declare-arg.ll
+# LLVM_SPIRV :: DebugInfo/X86/dbg-value-const-byref.ll
+# LLVM_SPIRV :: DebugInfo/X86/dw_op_minus_direct.ll
+# LLVM_SPIRV :: DebugInfo/X86/dwarf-aranges-no-dwarf-labels.ll
+# LLVM_SPIRV :: DebugInfo/X86/frame-register.ll
+# LLVM_SPIRV :: DebugInfo/X86/this-stack_value.ll
+# LLVM_SPIRV :: spirv-extensions-control.ll
+# LLVM_SPIRV :: transcoding/SPV_KHR_integer_dot_product-sat.ll
+# usually with segfaults in the middle of LLVM itself
+# this might be hopeless to get working
+makedepends=(${makedepends[@]//libclc/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/-D gallium-opencl=icd/-D gallium-opencl=disabled/
+ '
+ declare -f package_opencl-mesa | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+)"
diff --git a/build-support/rust140/PKGBUILD b/build-support/disabled/rust140/PKGBUILD
index 6d05c3a7..6d05c3a7 100644
--- a/build-support/rust140/PKGBUILD
+++ b/build-support/disabled/rust140/PKGBUILD
diff --git a/build-support/rust140/config.toml.patch b/build-support/disabled/rust140/config.toml.patch
index 8d0762cd..8d0762cd 100644
--- a/build-support/rust140/config.toml.patch
+++ b/build-support/disabled/rust140/config.toml.patch
diff --git a/build-support/rust140/watcher.sh b/build-support/disabled/rust140/watcher.sh
index 98228b5d..98228b5d 100755
--- a/build-support/rust140/watcher.sh
+++ b/build-support/disabled/rust140/watcher.sh
diff --git a/build-support/rust141/PKGBUILD b/build-support/disabled/rust141/PKGBUILD
index afa6ad96..afa6ad96 100644
--- a/build-support/rust141/PKGBUILD
+++ b/build-support/disabled/rust141/PKGBUILD
diff --git a/build-support/rust141/config.toml.patch b/build-support/disabled/rust141/config.toml.patch
index 8d0762cd..8d0762cd 100644
--- a/build-support/rust141/config.toml.patch
+++ b/build-support/disabled/rust141/config.toml.patch
diff --git a/build-support/rust141/rustc-1.41.0-src-typenum-U1024.patch b/build-support/disabled/rust141/rustc-1.41.0-src-typenum-U1024.patch
index d1484d5c..d1484d5c 100644
--- a/build-support/rust141/rustc-1.41.0-src-typenum-U1024.patch
+++ b/build-support/disabled/rust141/rustc-1.41.0-src-typenum-U1024.patch
diff --git a/build-support/rust148/PKGBUILD b/build-support/disabled/rust148/PKGBUILD
index 9ed1cba8..9ed1cba8 100644
--- a/build-support/rust148/PKGBUILD
+++ b/build-support/disabled/rust148/PKGBUILD
diff --git a/build-support/rust148/config.toml.patch b/build-support/disabled/rust148/config.toml.patch
index 8d0762cd..8d0762cd 100644
--- a/build-support/rust148/config.toml.patch
+++ b/build-support/disabled/rust148/config.toml.patch
diff --git a/build-support/rust157-bin/PKGBUILD b/build-support/disabled/rust157-bin/PKGBUILD
index 01f3e801..01f3e801 100644
--- a/build-support/rust157-bin/PKGBUILD
+++ b/build-support/disabled/rust157-bin/PKGBUILD
diff --git a/build-support/disabled/rust159-bin/PKGBUILD b/build-support/disabled/rust159-bin/PKGBUILD
new file mode 100644
index 00000000..205e3d61
--- /dev/null
+++ b/build-support/disabled/rust159-bin/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=rust159-bin
+pkgver=1.59.0
+pkgrel=1
+pkgdesc='Binary precompiled packages for Rust'
+url='https://www.rust-lang.org/'
+arch=(x86_64 pentium4 i686)
+license=('MIT' 'Apache')
+provides=('rust' 'cargo')
+conflicts=('rust' 'cargo')
+options=('!emptydirs')
+
+source_x86_64=("https://static.rust-lang.org/dist/rust-$pkgver-x86_64-unknown-linux-gnu.tar.gz"{,.asc})
+source_pentium4=("https://static.rust-lang.org/dist/rust-$pkgver-i686-unknown-linux-gnu.tar.gz"{,.asc})
+source_i686=("https://static.rust-lang.org/dist/rust-$pkgver-i686-unknown-linux-gnu.tar.gz"{,.asc})
+
+sha256sums_x86_64=('0c1c2da3fa26372e5178123aa5bb0fdcd4933fbad9bfb268ffbd71807182ecae'
+ 'SKIP')
+sha256sums_pentium4=('f57ebfafed1e857b2b1dc1a22cf1133766f68a0759dc2f717dec54a8d4385dec'
+ 'SKIP')
+sha256sums_i686=('f57ebfafed1e857b2b1dc1a22cf1133766f68a0759dc2f717dec54a8d4385dec'
+ 'SKIP')
+
+validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
+ '474E22316ABF4785A88C6E8EA2C794A986419D8A') # Tom Stellard <tstellar@redhat.com>
+
+case "${CARCH}" in
+ x86_64) _ARCH='x86_64-unknown-linux-gnu';;
+ i686|pentium4) _ARCH='i686-unknown-linux-gnu';;
+esac
+
+package() {
+ cd "rust-$pkgver-$_ARCH"
+
+ ./install.sh --prefix=/usr --destdir="$pkgdir"
+}
diff --git a/build-support/libsigc++-docs-dummy/PKGBUILD b/build-support/libsigc++-docs-dummy/PKGBUILD
index 1fea693a..1b6453d9 100644
--- a/build-support/libsigc++-docs-dummy/PKGBUILD
+++ b/build-support/libsigc++-docs-dummy/PKGBUILD
@@ -1,5 +1,5 @@
pkgname='libsigc++-docs-dummy'
-pkgver='2.10.7'
+pkgver='2.10.8'
pkgrel='1'
arch=('i486' 'i686' 'pentium4' 'x86_64')
pkgdesc="Developer documentation for libsigc++ - dummy package"