summaryrefslogtreecommitdiff
path: root/build-support/python-setuptools-bootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/python-setuptools-bootstrap/PKGBUILD')
-rw-r--r--build-support/python-setuptools-bootstrap/PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/build-support/python-setuptools-bootstrap/PKGBUILD b/build-support/python-setuptools-bootstrap/PKGBUILD
index 3ff26e3a..70162207 100644
--- a/build-support/python-setuptools-bootstrap/PKGBUILD
+++ b/build-support/python-setuptools-bootstrap/PKGBUILD
@@ -8,8 +8,9 @@
# heavily borrowed from python-setuptools' PKGBUILD
pkgname=python-setuptools-bootstrap
+pkgbase=python-setuptools
pkgver='56.2.0'
-pkgrel='1'
+pkgrel='2'
epoch='1'
pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages - bootstrap variant"
arch=('any')
@@ -55,5 +56,7 @@ package() {
replaces=('python-distribute')
cd "$srcdir"/setuptools-$pkgver
+ # create directory before installing (otherwise installing fails)
+ mkdir build/scripts-3.10
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
}