summaryrefslogtreecommitdiff
path: root/build-support/python-setuptools-bootstrap/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-16 12:55:01 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-16 12:55:01 +0100
commit0da508169fa2f28f17c6c6a25b82e7fe70805c37 (patch)
treebc3c03e883313334985199aec25521e3c3a91f84 /build-support/python-setuptools-bootstrap/PKGBUILD
parent43dbbe8adab1f9bc5b99d52323e8407d9451d36a (diff)
downloadpackages-0da508169fa2f28f17c6c6a25b82e7fe70805c37.tar.xz
build-support/python-setuptools-bootstrap: fixed pkgbase, fixed missing scripts dir
Diffstat (limited to 'build-support/python-setuptools-bootstrap/PKGBUILD')
-rw-r--r--build-support/python-setuptools-bootstrap/PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/build-support/python-setuptools-bootstrap/PKGBUILD b/build-support/python-setuptools-bootstrap/PKGBUILD
index 3ff26e3a..70162207 100644
--- a/build-support/python-setuptools-bootstrap/PKGBUILD
+++ b/build-support/python-setuptools-bootstrap/PKGBUILD
@@ -8,8 +8,9 @@
# heavily borrowed from python-setuptools' PKGBUILD
pkgname=python-setuptools-bootstrap
+pkgbase=python-setuptools
pkgver='56.2.0'
-pkgrel='1'
+pkgrel='2'
epoch='1'
pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages - bootstrap variant"
arch=('any')
@@ -55,5 +56,7 @@ package() {
replaces=('python-distribute')
cd "$srcdir"/setuptools-$pkgver
+ # create directory before installing (otherwise installing fails)
+ mkdir build/scripts-3.10
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
}