summaryrefslogtreecommitdiff
path: root/build-support/haskell-tasty-hunit-old/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/haskell-tasty-hunit-old/PKGBUILD')
-rw-r--r--build-support/haskell-tasty-hunit-old/PKGBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/build-support/haskell-tasty-hunit-old/PKGBUILD b/build-support/haskell-tasty-hunit-old/PKGBUILD
deleted file mode 100644
index 272cb5a6..00000000
--- a/build-support/haskell-tasty-hunit-old/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# $Id$
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
-
-_hkgname=tasty-hunit
-pkgname=haskell-tasty-hunit-old
-pkgver=0.9.2
-pkgrel=34
-pkgdesc="HUnit support for the Tasty test framework."
-url="http://documentup.com/feuerbach/tasty"
-license=("MIT")
-arch=('i686' 'x86_64')
-depends=('ghc-libs' "haskell-tasty")
-makedepends=('ghc')
-source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha512sums=('f7af615938d8cb9ec40114fc27f196a8bc9991b0aefca9c5de72bdb6872073b6d771f276472f831b8c583eade3d2d1413aee8f194befa450631bdf3ed50ed439')
-provides=("haskell-tasty-hunit=${pkgver}")
-conflicts=('haskell-tasty-hunit')
-replaces=('haskell-tasty-hunit')
-
-build() {
- cd "${srcdir}/${_hkgname}-${pkgver}"
-
- runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname%-*}" \
- --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
- runhaskell Setup build
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
-}
-
-package() {
- cd "${srcdir}/${_hkgname}-${pkgver}"
-
- install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname%-*}.sh"
- install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname%-*}.sh"
- runhaskell Setup copy --destdir="${pkgdir}"
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-*}/LICENSE"
- rm -f "${pkgdir}/usr/share/doc/${pkgname%-*}/LICENSE"
-}