summaryrefslogtreecommitdiff
path: root/build-support/disabled/releng
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/disabled/releng')
-rw-r--r--build-support/disabled/releng/archiso32-git/PKGBUILD31
-rw-r--r--build-support/disabled/releng/asp32-git/PKGBUILD25
2 files changed, 56 insertions, 0 deletions
diff --git a/build-support/disabled/releng/archiso32-git/PKGBUILD b/build-support/disabled/releng/archiso32-git/PKGBUILD
new file mode 100644
index 00000000..ee776241
--- /dev/null
+++ b/build-support/disabled/releng/archiso32-git/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sebastian Lau <lauseb644@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+
+_pkgname=archiso32
+pkgname="${_pkgname}-git"
+pkgver=i686.33.2.g1e308c7
+pkgrel=1
+pkgdesc="Arch Linux 32 livecd/liveusb generation scripts"
+arch=('any')
+url="http://archlinux32.org"
+license=('GPL')
+depends=('libisoburn' 'squashfs-tools' 'btrfs-progs' 'dosfstools' 'lynx' 'arch-install-scripts')
+optdepends=('qemu: quickly test isos')
+makedepends=('git')
+provides=('archiso')
+conflicts=('archiso')
+source=("git://github.com/archlinux32/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/-/./g;s/v//'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ make DESTDIR="${pkgdir}/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/build-support/disabled/releng/asp32-git/PKGBUILD b/build-support/disabled/releng/asp32-git/PKGBUILD
new file mode 100644
index 00000000..5eaa912e
--- /dev/null
+++ b/build-support/disabled/releng/asp32-git/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=asp32-git
+pkgver=1
+pkgrel=1
+pkgdesc="Arch Linux build source file management tool (for Archlinux32)"
+arch=(any)
+url="https://git.archlinux32.org/archlinux32/asp32"
+license=(MIT)
+depends=(awk bash jq git libarchive)
+conflicts=(asp)
+makedepends=(asciidoc)
+source=("git+https://git.archlinux32.org/archlinux32/asp32.git")
+md5sums=('SKIP')
+
+build() {
+ make -C asp32
+}
+
+package() {
+ make -C asp32 PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 asp32/LICENSE "$pkgdir/usr/share/licenses/asp/LICENSE"
+}
+
+# vim: ft=sh syn=sh et