summaryrefslogtreecommitdiff
path: root/build-support/disabled/libfm-extra/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/disabled/libfm-extra/PKGBUILD')
-rw-r--r--build-support/disabled/libfm-extra/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/build-support/disabled/libfm-extra/PKGBUILD b/build-support/disabled/libfm-extra/PKGBUILD
new file mode 100644
index 00000000..3ee20db8
--- /dev/null
+++ b/build-support/disabled/libfm-extra/PKGBUILD
@@ -0,0 +1,33 @@
+# breaking the cycle with menu-cache on i486
+depends=(${depends[@]//menu-cache/})
+depends_i686+=(menu-cache)
+depends_pentium4=("${depends_i686[@]}")
+
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|./configure --with-extra-only |
+ /mv.*\/usr\/bin/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_libfm | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+ eval "$(
+ declare -f package_libfm-gtk2 | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+ eval "$(
+ declare -f package_libfm-gtk3 | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+fi