summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/binutils/PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index 2aab24cb..3c6de6b6 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -6,7 +6,7 @@ eval "$(
'
)"
-# enable BFD for x86_64 other we have problems with cross-compilation
+# enable BFD for x86_64 otherwise we have problems with cross-compilation
# or compiling things like grub
eval "$(
declare -f build | \
@@ -56,6 +56,16 @@ else
)"
fi
+# i486-specific: disable PGO/LTO build, uses too much resources
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-pgo-build=.*/--disable-pgo-build/
+ '
+ )"
+fi
+
# 2.38, FAIL: Build ifunc-1a with PIE -z ibtplt
eval "$(
declare -f check | \