summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/python-build/PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/community/python-build/PKGBUILD b/community/python-build/PKGBUILD
index aa0b6613..7b473826 100644
--- a/community/python-build/PKGBUILD
+++ b/community/python-build/PKGBUILD
@@ -1,4 +1,10 @@
-# cycle breaking for python-sphinx
+# disable documentation (needs sphinx, sphinx-furo)
+# python-sphinx-furo needs npm, which is broken on archlinux32
+# most likely since years..
+makedepends=(${makedepends[@]//python-sphinx-furo/})
+makedepends=(${makedepends[@]//python-sphinx-argparse-cli/})
+makedepends=(${makedepends[@]//python-sphinx-autodoc-typehints/})
+makedepends=(${makedepends[@]//python-sphinx/})
eval "$(
declare -f build | \
sed '
@@ -9,11 +15,3 @@ eval "$(
/.*\/share\/doc.*/d
'
)"
-
-# disable documentation (needs spinx, furo)
-# python-sphinx_furo neds npm, which is broken on archlinux32
-# most likely since years..
-makedepends=(${makedepends[@]//python-sphinx-furo/})
-makedepends=(${makedepends[@]//python-sphinx-argparse-cli/})
-makedepends=(${makedepends[@]//python-sphinx-autodoc-typehints/})
-makedepends=(${makedepends[@]//python-sphinx/})