summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/meson/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/extra/meson/PKGBUILD b/extra/meson/PKGBUILD
index 0f009bb1..74cfa56b 100644
--- a/extra/meson/PKGBUILD
+++ b/extra/meson/PKGBUILD
@@ -16,3 +16,16 @@ checkdepends_pentium4=("${checkdepends_i686[@]}")
# still far too many tests fail, ignoring for now
unset check
unset checkdepends
+
+# do not set b_lto to true in arch-meson wrapper on i486
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ {
+ declare -f package || \
+ printf 'package() {\n}\n'
+ } \
+ | sed '
+ $i sed -i "s/b_lto=.*/b_lto=false/" "$pkgdir/usr/bin/arch-meson"
+ '
+ )"
+fi