summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/mesa/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
index 1a597eca..34664716 100644
--- a/extra/mesa/PKGBUILD
+++ b/extra/mesa/PKGBUILD
@@ -150,3 +150,28 @@ if [ "$CARCH" == 'i486' ]; then
'
)"
fi
+
+# libclc needs spirv-llvm-translator which throws heavily errors on 32-bit
+# LLVM_SPIRV :: DebugInfo/X86/dbg-declare-alloca.ll
+# LLVM_SPIRV :: DebugInfo/X86/dbg-declare-arg.ll
+# LLVM_SPIRV :: DebugInfo/X86/dbg-value-const-byref.ll
+# LLVM_SPIRV :: DebugInfo/X86/dw_op_minus_direct.ll
+# LLVM_SPIRV :: DebugInfo/X86/dwarf-aranges-no-dwarf-labels.ll
+# LLVM_SPIRV :: DebugInfo/X86/frame-register.ll
+# LLVM_SPIRV :: DebugInfo/X86/this-stack_value.ll
+# LLVM_SPIRV :: spirv-extensions-control.ll
+# LLVM_SPIRV :: transcoding/SPV_KHR_integer_dot_product-sat.ll
+# usually with segfaults in the middle of LLVM itself
+# this might be hopeless to get working
+makedepends=(${makedepends[@]//libclc/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/-D gallium-opencl=icd/-D gallium-opencl=disabled/
+ '
+ declare -f package_opencl-mesa | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+)"