summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/glibc/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index 12033416..83751716 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -42,4 +42,13 @@ if [ "${CARCH}" = "i486" ]; then
/make check/d
'
)"
+
+ # disable CET (Control Flow instructions endbr32/enbr64)
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-cet/--disable-cet/
+ '
+ )"
+
fi