summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build-support/rime-luna-pinyin-bootstrap/PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/build-support/rime-luna-pinyin-bootstrap/PKGBUILD b/build-support/rime-luna-pinyin-bootstrap/PKGBUILD
index 684430a8..2be02bd8 100644
--- a/build-support/rime-luna-pinyin-bootstrap/PKGBUILD
+++ b/build-support/rime-luna-pinyin-bootstrap/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=rime-luna-pinyin-bootstrap
+_pkgname=${pkgname%-*}
pkgver=0.0.0.20200410
conflicts=(rime-luna-pinyin)
provides=("rime-luna-pinyin=$pkgver")
@@ -17,18 +18,18 @@ source=("https://github.com/rime/rime-luna-pinyin/archive/$_commit/rime-luna-pin
sha512sums=('5a4f91f04f807ba84650a52acf8f634382c32eb978e8895f97b05594ea90cf6771386bb80cda1b694905c50d64cf8b4e8514abb762c4d18035b73c67148339f9')
prepare() {
- cd $pkgname-$_commit
+ cd $_pkgname-$_commit
# Link essentials
for _f in $(pacman -Qql rime-prelude rime-essay | grep -v "/$"); do ln -sf $_f; done
}
build(){
- cd $pkgname-$_commit
+ cd $_pkgname-$_commit
for _s in $(ls *.schema.yaml); do rime_deployer --compile $_s; done
}
package() {
- cd $pkgname-$_commit
+ cd $_pkgname-$_commit
find . -type l -delete
rm build/*.txt
install -Dm644 *.yaml -t "$pkgdir"/usr/share/rime-data/