summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/mono/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/mono/PKGBUILD b/extra/mono/PKGBUILD
new file mode 100644
index 00000000..bccd03b7
--- /dev/null
+++ b/extra/mono/PKGBUILD
@@ -0,0 +1,14 @@
+if [ "$CARCH" = 'i486' ]; then
+ # these atomics are unavailable on i486, but that is not detected (?)
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /^}$/ i \
+ sed -i '"'"' \
+ /#define BROKEN_64BIT_ATOMICS_INTRINSIC 1/ i \\\
+ #endif \\\
+ #if true \
+ '"'"' mono/utils/atomic.h
+ '
+ )"
+fi