summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/apr/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/apr/PKGBUILD b/extra/apr/PKGBUILD
new file mode 100644
index 00000000..f11a97b8
--- /dev/null
+++ b/extra/apr/PKGBUILD
@@ -0,0 +1,9 @@
+# disable compiler atomics on u486
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-nonportable-atomics/--disable-nonportable-atomics/
+ '
+ )"
+fi