summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--blacklist/i486/rust/poppler3
-rw-r--r--extra/poppler/PKGBUILD19
2 files changed, 19 insertions, 3 deletions
diff --git a/blacklist/i486/rust/poppler b/blacklist/i486/rust/poppler
deleted file mode 100644
index 8f84c1a1..00000000
--- a/blacklist/i486/rust/poppler
+++ /dev/null
@@ -1,3 +0,0 @@
-blocked by cairo
-blocked by gtk3
-blocked by qt5-base
diff --git a/extra/poppler/PKGBUILD b/extra/poppler/PKGBUILD
new file mode 100644
index 00000000..dcff5d6e
--- /dev/null
+++ b/extra/poppler/PKGBUILD
@@ -0,0 +1,19 @@
+# no gtk3 and qt5-base on i486 (yet)
+# gtk3 seems to be auto-detected (there is a switch in build(), but it
+# does not need to be set to "OFF" apparently).
+makedepends=(
+ $(
+ printf '%s\n' "${makedepends[@]}" \
+ | grep -vxF gtk3 \
+ | grep -vxF qt5-base
+ )
+)
+makedepends_i686+=(gtk3 qt5base)
+makedepends_pentium4+=(gtk3 qt5base)
+
+eval "$(
+ declare -f package_poppler-qt5 \
+ | sed '
+ /^\s*cd build;/i [ "${CARCH}" != i486 ] || return 0
+ '
+)"