summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/qt5-base/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index 6df4ee22..0934cf81 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -17,3 +17,14 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# enable XCB explicitely for now on i486 (rather fail early than to
+# get weird startup messages of Qt5 applications hours later)
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure -xcb /
+ '
+ )"
+fi