summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/thunderbird/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/thunderbird/PKGBUILD b/extra/thunderbird/PKGBUILD
index 33e3f300..b7adf6b6 100644
--- a/extra/thunderbird/PKGBUILD
+++ b/extra/thunderbird/PKGBUILD
@@ -9,3 +9,20 @@ eval "$(
s/ac_add_options --enable-linker=gold/ac_add_options --enable-linker=bfd/
'
)"
+
+# from VoidLinux, avoid excessive debug symbols in rust leading
+# to out-of-memory situations
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a sed -i \"s/debug_info = '2'/debug_info = '1'/\" build/moz.configure/toolchain.configure
+ '
+)"
+
+# don't kill build slaves by auto-guessing available CPU cores
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a export MOZ_MAKE_FLAGS=-j1
+ '
+)"