summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/gtk4/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/gtk4/PKGBUILD b/extra/gtk4/PKGBUILD
index 20cb4c4a..9173941a 100644
--- a/extra/gtk4/PKGBUILD
+++ b/extra/gtk4/PKGBUILD
@@ -20,3 +20,12 @@ eval "$(
/^\s*mv /d
'
)"
+
+# Vala is not bootstrapped on i486
+# (this affect libcloudproviders, tracker3)
+# gst-plugins-bad-libs have too many dependencies not available yet on i486
+if [ "$CARCH" = 'i486' ]; then
+ depends=(${depends[@]//tracker3/})
+ depends=(${depends[@]//libcloudproviders/})
+ depends=(${depends[@]//gst-plugins-bad-libs/})
+fi