summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/firefox/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 823834f5..6c6a7965 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -234,3 +234,14 @@ eval "$(
$ i patch -p1 -i "$srcdir/firefox-99.0.1-fdlibm-double.patch"
'
)"
+
+# disable stripping in mozconfig.<arch> (insists to use llvm-strip which runs
+# out of memory on libxul.so. Now 2.5 GB can be strupped to 166 MB, so we do
+# that with the normal 'strip' from binutils after 'mach install'
+eval "$(
+ declare -f package | \
+ sed '
+ /.*mach.*install/ a \
+ strip "$pkgdir/usr/lib/$pkgname/libxul.so"
+ '
+)"