summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build-support/graphite-no-docs/PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/build-support/graphite-no-docs/PKGBUILD b/build-support/graphite-no-docs/PKGBUILD
new file mode 100644
index 00000000..03849a16
--- /dev/null
+++ b/build-support/graphite-no-docs/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=graphite-no-docs
+pkgver=1.3.13
+pkgrel=1
+epoch=1
+arch=('i486' 'i686' 'pentium4' 'x86_64')
+url="https://github.com/silnrsi/graphite"
+pkgdesc='reimplementation of the SIL Graphite text processing engine - without documentation'
+license=('LGPL' 'GPL' 'custom')
+depends=('gcc-libs')
+makedepends=('cmake' 'freetype2' 'python')
+options=('!emptydirs')
+source=(https://github.com/silnrsi/graphite/releases/download/${pkgver}/graphite2-${pkgver}.tgz)
+sha1sums=('bd3494575a1ff1c5b4ea796444274dab1e5992c9')
+
+provides=("graphite=$pkgver")
+
+prepare() {
+ cd "${srcdir}"
+
+ # python2 fixes
+#sed -i "s:\/usr\/bin\/python:\/usr\/bin\/python2:" graphite2-${pkgver}/tests/{corrupt.py,defuzz,fnttxtrender,hbspeeds,jsoncmp}
+}
+
+build() {
+ mkdir build
+ cd build
+ cmake -G "Unix Makefiles" ../graphite2-${pkgver} \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DGRAPHITE2_COMPARE_RENDERER=OFF \
+
+ # fix unwanted -O3 cflag (taken form Debian)
+ find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
+
+ make
+}
+
+package() {
+ cd "${srcdir}"/build
+ make DESTDIR="$pkgdir/" install
+ # install doc files
+ mkdir -p "${pkgdir}"/usr/share/doc/graphite2/api
+
+ # licenses
+ mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -m644 "${srcdir}"/graphite2-${pkgver}/COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/
+}