summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/firefox/PKGBUILD4
-rw-r--r--extra/firefox/mozconfig-i686.patch2
-rw-r--r--extra/firefox/mozconfig-pentium4.patch2
3 files changed, 6 insertions, 2 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index d466d812..823834f5 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -4,7 +4,7 @@
# set correct compiler and toochain tools
if [ "${CARCH}" = "pentium4" ]; then
source+=('mozconfig-pentium4.patch')
- sha256sums+=('ca75f01d9c56fff5de04395ec91b65fb87d94bc8d10acd44472d50ca8deaeda6')
+ sha256sums+=('6aafff15bc3e11137a295869c16bf07aaf110f5fa39545bb27da1a182d1e9b4a')
eval "$(
declare -f prepare | \
sed '
@@ -14,7 +14,7 @@ eval "$(
fi
if [ "${CARCH}" = "i686" ]; then
source+=('mozconfig-i686.patch')
- sha256sums+=('3de39ec7cdb2305ae635666e2909739c44d2270a8733faff90d5439c92149cdd')
+ sha256sums+=('56f7faa75bc16b9948c37e84309efd59c7d932a6f9a579135040fa7f94da35db')
eval "$(
declare -f prepare | \
sed '
diff --git a/extra/firefox/mozconfig-i686.patch b/extra/firefox/mozconfig-i686.patch
index bfe954a0..f4d3c077 100644
--- a/extra/firefox/mozconfig-i686.patch
+++ b/extra/firefox/mozconfig-i686.patch
@@ -19,8 +19,10 @@ diff -rauN a/mozconfig b/mozconfig
+
+# pentium4 specific options
+ac_add_options --disable-lto
++ac_add_options --disable-install-strip
+export CC=gcc-10
+export CXX=g++-10
+export AR=gcc-ar-10
+export NM=gcc-nm-10
+export RANLIB=gcc-ranlib-10
++export STRIP=strip
diff --git a/extra/firefox/mozconfig-pentium4.patch b/extra/firefox/mozconfig-pentium4.patch
index ff2b1602..0201a74f 100644
--- a/extra/firefox/mozconfig-pentium4.patch
+++ b/extra/firefox/mozconfig-pentium4.patch
@@ -17,8 +17,10 @@ diff -rauN a/mozconfig b/mozconfig
+
+# pentium4 specific options
+ac_add_options --disable-lto
++ac_add_options --disable-install-strip
+export CC=gcc-10
+export CXX=g++-10
+export AR=gcc-ar-10
+export NM=gcc-nm-10
+export RANLIB=gcc-ranlib-10
++export STRIP=strip