summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-18 15:27:13 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-18 15:27:13 +0000
commitd59a7169539efa25456c18211810d10f6356229e (patch)
treeafb0ae2e0b5a53b98759093dfa7107a05f14ba8f /extra
parentecf507dfe8456d8c249156cfadafef195980fea7 (diff)
downloadpackages-d59a7169539efa25456c18211810d10f6356229e.tar.xz
extra/nasm: added i486-specific patch
Diffstat (limited to 'extra')
-rw-r--r--extra/nasm/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/extra/nasm/PKGBUILD b/extra/nasm/PKGBUILD
new file mode 100644
index 00000000..f644e426
--- /dev/null
+++ b/extra/nasm/PKGBUILD
@@ -0,0 +1,20 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # remove all fonts and ghostscript (we don't build the manual)
+ makedepends=(${makedepends[@]//perl-font-ttf/})
+ makedepends=(${makedepends[@]//perl-sort-versions/})
+ makedepends=(${makedepends[@]//fontconfig/})
+ makedepends=(${makedepends[@]//adobe-source-sans-pro-fonts/})
+ makedepends=(${makedepends[@]//ttf-liberation/})
+ makedepends=(${makedepends[@]//ghostscript/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ /make .*doc/d
+ '
+ )"
+fi
+
+# orginal download link unstable
+#sed -i 's@http://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}.tar.xz@https://ftp.osuosl.org/pub/blfs/conglomeration/${pkgname}/${pkgname}-${pkgver}.tar.xz@' PKGBUILD