summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-07 13:36:28 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-07 13:36:28 +0000
commitbc84bb5521096efecb4ee87805ce5e8f69a25a6d (patch)
tree818c12d4e2deb204cc9bb69438d627c492f27298 /extra
parent192629f0c014a7098829614a0df8aa4e75f7f88c (diff)
downloadpackages-bc84bb5521096efecb4ee87805ce5e8f69a25a6d.tar.xz
extra/git: added i486 specific patches
Diffstat (limited to 'extra')
-rw-r--r--extra/git/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/git/PKGBUILD b/extra/git/PKGBUILD
index e69de29b..4e8184da 100644
--- a/extra/git/PKGBUILD
+++ b/extra/git/PKGBUILD
@@ -0,0 +1,19 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ echo 486
+ # we currently have no Gnome and libsecret, so disable integration
+ makedepends=(${makedepends[@]//libgnome-keyring/})
+ makedepends=(${makedepends[@]//libsecret/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s@\(make -C contrib/credential/gnome-keyring\)@#\1@
+ s@\(make -C contrib/credential/libsecret\)@#\1@
+ '
+ declare -f package | \
+ sed '
+ /gnome-keyring/d
+ /libsecret/d
+ '
+ )"
+fi