summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2022-05-02 18:45:56 +0200
committerErich Eckner <git@eckner.net>2022-05-02 22:06:39 +0200
commit6d1350c750993efcbe4a99a981dfda5a8a81cfa6 (patch)
tree00d5fb4cd1e4aba60b2dbee168c13d5c4e68bab8 /extra
parent7e7795819d6d4a801d7d45aafc7dbc19c4410030 (diff)
downloadpackages-6d1350c750993efcbe4a99a981dfda5a8a81cfa6.tar.xz
Revert "extra/linux-zen: disabled archive-server"
This reverts commit f6636f6979f77d9ffe8c836d8681678993a94db4.
Diffstat (limited to 'extra')
-rw-r--r--extra/linux-zen/PKGBUILD116
1 files changed, 58 insertions, 58 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index 32175dee..9ea8014c 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -19,65 +19,65 @@ eval "$(
)"
# use our tarballer instead of cloning from git
-#~ for ((i=0; i<${#source[@]}; i++)); do
- #~ infos=$(
- #~ printf '%s\n' "${source[${i}]}" | \
- #~ sed '
- #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
- #~ t
- #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
- #~ t
- #~ d
- #~ '
- #~ )
- #~ if [ -n "${infos}" ]; then
- #~ source[${i}]=$(
- #~ type="${infos%% *}"
- #~ infos="${infos#* }"
- #~ if [ -n "${infos%% *}" ]; then
- #~ prefix="${infos%% *}"
- #~ else
- #~ prefix=''
- #~ fi
- #~ infos="${infos#* }"
- #~ repo="${infos%% *}"
- #~ repo64=$(
- #~ printf '%s' "${repo}" | \
- #~ base64 -w0 | \
- #~ sed 's/=/%3D/g'
- #~ )
- #~ infos="${infos#* }"
- #~ if [ "${infos%% *}" = '?signed' ]; then
- #~ key_check=$(
- #~ printf '&valid_keys='
- #~ printf '%s,' "${validpgpkeys[@]}" | \
- #~ sed 's/,$//'
- #~ )
- #~ else
- #~ key_check=''
- #~ fi
- #~ infos="${infos#* }"
- #~ if [ -z "${prefix}" ]; then
- #~ prefix="${repo%.git}"
- #~ prefix="${prefix##*/}"
- #~ fi
- #~ prefix_64=$(
- #~ printf '%s/' "${prefix}" | \
- #~ base64 -w0 | \
- #~ sed 's/=/%3D/g'
- #~ )
+for ((i=0; i<${#source[@]}; i++)); do
+ infos=$(
+ printf '%s\n' "${source[${i}]}" | \
+ sed '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ t
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ t
+ d
+ '
+ )
+ if [ -n "${infos}" ]; then
+ source[${i}]=$(
+ type="${infos%% *}"
+ infos="${infos#* }"
+ if [ -n "${infos%% *}" ]; then
+ prefix="${infos%% *}"
+ else
+ prefix=''
+ fi
+ infos="${infos#* }"
+ repo="${infos%% *}"
+ repo64=$(
+ printf '%s' "${repo}" | \
+ base64 -w0 | \
+ sed 's/=/%3D/g'
+ )
+ infos="${infos#* }"
+ if [ "${infos%% *}" = '?signed' ]; then
+ key_check=$(
+ printf '&valid_keys='
+ printf '%s,' "${validpgpkeys[@]}" | \
+ sed 's/,$//'
+ )
+ else
+ key_check=''
+ fi
+ infos="${infos#* }"
+ if [ -z "${prefix}" ]; then
+ prefix="${repo%.git}"
+ prefix="${prefix##*/}"
+ fi
+ prefix_64=$(
+ printf '%s/' "${prefix}" | \
+ base64 -w0 | \
+ sed 's/=/%3D/g'
+ )
- #~ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- #~ "${prefix}" \
- #~ "${pkgver}" \
- #~ "${type}" \
- #~ "${prefix_64}" \
- #~ "${repo64}" \
- #~ "${key_check}" \
- #~ "${infos}"
- #~ )
- #~ fi
-#~ done
+ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
+ "${prefix}" \
+ "${pkgver}" \
+ "${type}" \
+ "${prefix_64}" \
+ "${repo64}" \
+ "${key_check}" \
+ "${infos}"
+ )
+ fi
+done
# temporary (FS32#163)
eval "$(