summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-29 18:16:16 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-29 18:16:16 +0200
commit6995161c3262649166ef86e1f6ae71d29a7103c4 (patch)
tree6c79300c8cad5006c0d8083d0b4adb63627ed0fd /extra
parent438f86c4569e331d85732f18a8c3ccd1686096a7 (diff)
downloadpackages-6995161c3262649166ef86e1f6ae71d29a7103c4.tar.xz
extra/chromium: more i686 patching, no sse fpmath
Diffstat (limited to 'extra')
-rw-r--r--extra/chromium/PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/extra/chromium/PKGBUILD b/extra/chromium/PKGBUILD
index c5c8667e..f0bf949b 100644
--- a/extra/chromium/PKGBUILD
+++ b/extra/chromium/PKGBUILD
@@ -36,13 +36,15 @@ eval "$(
)"
# disable SSE2 for i686 (no i486 yet, flags are in the same place for MMX and SSE math, but
-# we don't even have a gui yet)
+# we don't even have a gui yet), also disable SSE math as this is not supported with march=i686
+# (at least gcc)
if [ "$CARCH" = 'i686' ]; then
eval "$(
declare -f build | \
sed '
/gn gen/ i \
- sed -i '\''s/"-msse2"/""/'\'' build/config/compiler/BUILD.gn
+ sed -i '\''s/"-msse2"/""/'\'' build/config/compiler/BUILD.gn \
+ sed -i '\''s/"-mfpmath=sse"/""/'\'' build/config/compiler/BUILD.gn
'
)"
fi