summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-03-10 15:25:22 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2019-03-10 15:25:22 +0100
commit567531c87ce06a251c50cf283a0ec58960b27dc2 (patch)
tree6a216ae8787c58ee1cde054b7406d6d669555eec /extra
parent9aec669b08f89ce19ce073e018f5c4f7e3153048 (diff)
downloadpackages-567531c87ce06a251c50cf283a0ec58960b27dc2.tar.xz
extra/rust: patched i686 for pentium3 (no SSE2)
Diffstat (limited to 'extra')
-rw-r--r--extra/rust/PKGBUILD11
-rw-r--r--extra/rust/config.toml.patch9
2 files changed, 20 insertions, 0 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
new file mode 100644
index 00000000..b0b2eada
--- /dev/null
+++ b/extra/rust/PKGBUILD
@@ -0,0 +1,11 @@
+source+=(config.toml.patch)
+sha256sums+=('55d59786b6a24590951688c01910ac331996fc5ea5e20f10d227db24b93b1e74')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/config.toml.patch"
+ /}/ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/vendor/rustc-ap-rustc_target/spec/i686_unknown_linux_gnu.rs"
+ /}/ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/src/librustc_target/spec/i686_unknown_linux_gnu.rs"
+ '
+)"
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
new file mode 100644
index 00000000..f479499b
--- /dev/null
+++ b/extra/rust/config.toml.patch
@@ -0,0 +1,9 @@
+--- a/config.toml 2019-01-20 19:03:26.718067950 +0100
++++ b/config.toml 2019-01-20 19:03:52.614834201 +0100
+@@ -25,3 +25,6 @@
+
+ [target.x86_64-unknown-linux-gnu]
+ llvm-config = "/usr/bin/llvm-config"
++
++[target.i686-unknown-linux-gnu]
++llvm-config = "/usr/bin/llvm-config"