summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-08-07 05:16:56 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-08-07 05:16:56 +0200
commit47fc1caa389a0766493d557ddee0b417dc81d2ba (patch)
tree8dbfaf8206c28a5ff817fbea664a9d839e22048e /extra
parent50d7864c2b27b22caae3716f57a00e5d63b13cd8 (diff)
downloadpackages-47fc1caa389a0766493d557ddee0b417dc81d2ba.tar.xz
extra/libmypaint: applied update.patch from upstream, see FS#63393
Diffstat (limited to 'extra')
-rw-r--r--extra/libmypaint/PKGBUILD11
-rw-r--r--extra/libmypaint/autogen.patch23
-rw-r--r--extra/libmypaint/gegl-0.4.patch81
3 files changed, 115 insertions, 0 deletions
diff --git a/extra/libmypaint/PKGBUILD b/extra/libmypaint/PKGBUILD
new file mode 100644
index 00000000..89ef52c7
--- /dev/null
+++ b/extra/libmypaint/PKGBUILD
@@ -0,0 +1,11 @@
+# https://bugs.archlinux.org/task/63393
+
+source+=('autogen.patch')
+sha512sums+=('78cd5c2d409dee1df94cd9f94de96a38cc7677016aad6d3df596e3ed46fff62a7e009dbdde1ab9cefacb903e31d38f81f0a66f4fac30cf377e22f49a29ab25ef')
+sha512sums[2]='74432fc7bc5f42eb6fcd33c678709c5ade84b1ddfcfa2c5a499b66b2a7eae0f34ae90b67b1fab347d3bfd45b37d0a0011c49a75d2d17ab5a0c5df1a458b1b249'
+eval "$(
+ declare -f prepare | \
+ sed '
+ 5 a patch -p1 -i "$srcdir/autogen.patch"
+ '
+)"
diff --git a/extra/libmypaint/autogen.patch b/extra/libmypaint/autogen.patch
new file mode 100644
index 00000000..970cc94d
--- /dev/null
+++ b/extra/libmypaint/autogen.patch
@@ -0,0 +1,23 @@
+From 40d9077a80be13942476f164bddfabe842ab2a45 Mon Sep 17 00:00:00 2001
+From: Jehan <jehan@girinstud.io>
+Date: Thu, 22 Mar 2018 13:11:10 +0100
+Subject: [PATCH] autogen: adding support of automake 1.16.
+
+---
+ autogen.sh | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/autogen.sh b/autogen.sh
+index 50e509d..8fe7a7c 100755
+--- a/autogen.sh
++++ b/autogen.sh
+@@ -127,6 +127,9 @@ echo -n "checking for automake >= $AUTOMAKE_REQUIRED_VERSION ... "
+ if ($AUTOMAKE --version) < /dev/null > /dev/null 2>&1; then
+ AUTOMAKE=$AUTOMAKE
+ ACLOCAL=$ACLOCAL
++elif (automake-1.16 --version) < /dev/null > /dev/null 2>&1; then
++ AUTOMAKE=automake-1.16
++ ACLOCAL=aclocal-1.16
+ elif (automake-1.15 --version) < /dev/null > /dev/null 2>&1; then
+ AUTOMAKE=automake-1.15
+ ACLOCAL=aclocal-1.15
diff --git a/extra/libmypaint/gegl-0.4.patch b/extra/libmypaint/gegl-0.4.patch
new file mode 100644
index 00000000..d9d2d41e
--- /dev/null
+++ b/extra/libmypaint/gegl-0.4.patch
@@ -0,0 +1,81 @@
+diff -u -r libmypaint-1.3.0/configure.ac libmypaint-1.3.0-gegl/configure.ac
+--- libmypaint-1.3.0/configure.ac 2018-05-13 16:49:44.997077642 +0200
++++ libmypaint-1.3.0-gegl/configure.ac 2018-05-13 16:49:36.223744476 +0200
+@@ -45,7 +45,7 @@
+
+ ## Dependencies ##
+
+-m4_define([gegl_required_version], [0.3])
++m4_define([gegl_required_version], [0.4])
+ m4_define([introspection_required_version], [1.32.0])
+
+ AC_INIT([libmypaint],
+@@ -336,7 +336,7 @@
+ )
+
+ if eval "test x$enable_gegl = xyes"; then
+- PKG_CHECK_MODULES(GEGL, gegl-0.3 >= gegl_required_version)
++ PKG_CHECK_MODULES(GEGL, gegl-0.4 >= gegl_required_version)
+ fi
+ AM_CONDITIONAL(ENABLE_GEGL, test "x$enable_gegl" = "xyes")
+
+diff -u -r libmypaint-1.3.0/gegl/libmypaint-gegl.pc.in libmypaint-1.3.0-gegl/gegl/libmypaint-gegl.pc.in
+--- libmypaint-1.3.0/gegl/libmypaint-gegl.pc.in 2016-12-01 23:47:14.000000000 +0100
++++ libmypaint-1.3.0-gegl/gegl/libmypaint-gegl.pc.in 2018-05-13 16:50:16.620410376 +0200
+@@ -6,6 +6,6 @@
+ Name: libmypaint
+ Description: MyPaint brush engine library, with GEGL integration.
+ Version: @LIBMYPAINT_VERSION@
+-Requires: gegl-0.3 libmypaint
++Requires: gegl-0.4 libmypaint
+ Cflags: -I${includedir}/libmypaint-gegl
+ Libs: -L${libdir} -lmypaint-gegl
+diff -u -r libmypaint-1.3.0/gegl/Makefile.am libmypaint-1.3.0-gegl/gegl/Makefile.am
+--- libmypaint-1.3.0/gegl/Makefile.am 2018-05-13 16:48:53.437078622 +0200
++++ libmypaint-1.3.0-gegl/gegl/Makefile.am 2018-05-13 16:49:58.523744053 +0200
+@@ -11,7 +11,7 @@
+ INTROSPECTION_GIRS =
+ INTROSPECTION_SCANNER_ARGS = \
+ --warn-all \
+- --pkg="gegl-0.3" \
++ --pkg="gegl-0.4" \
+ --pkg="glib-2.0" \
+ --namespace="MyPaintGegl" \
+ --nsversion="$(LIBMYPAINT_MAJOR_VERSION).$(LIBMYPAINT_MINOR_VERSION)" \
+@@ -38,7 +38,7 @@
+ mypaint-gegl-surface.c
+
+ MyPaintGegl-@LIBMYPAINT_MAJOR_VERSION@.@LIBMYPAINT_MINOR_VERSION@.gir: libmypaint-gegl-@LIBMYPAINT_API_PLATFORM_VERSION@.la Makefile
+-MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_INCLUDES = GObject-2.0 MyPaint-$(LIBMYPAINT_MAJOR_VERSION).$(LIBMYPAINT_MINOR_VERSION) Gegl-0.3
++MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_INCLUDES = GObject-2.0 MyPaint-$(LIBMYPAINT_MAJOR_VERSION).$(LIBMYPAINT_MINOR_VERSION) Gegl-0.4
+ MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_CFLAGS = $(AM_CFLAGS) $(AM_CPPFLAGS) -I. -I..
+ MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_LIBS = libmypaint-gegl-@LIBMYPAINT_API_PLATFORM_VERSION@.la ../libmypaint-@LIBMYPAINT_API_PLATFORM_VERSION@.la
+ MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_FILES = $(introspection_sources)
+diff --git a/gegl/mypaint-gegl-surface.c b/gegl/mypaint-gegl-surface.c
+index 5c86d3c..622dd97 100644
+--- a/gegl/mypaint-gegl-surface.c
++++ b/gegl/mypaint-gegl-surface.c
+@@ -78,7 +78,11 @@ tile_request_start(MyPaintTiledSurface *tiled_surface, MyPaintTileRequest *reque
+
+ if (buffer_is_native(self)) {
+ GeglBufferIterator *iterator = gegl_buffer_iterator_new(self->buffer, &tile_bbox, 0, self->format,
++#if GEGL_MAJOR_VERSION == 0 && GEGL_MINOR_VERSION == 4 && GEGL_MICRO_VERSION >= 14
++ read_write_flags, GEGL_ABYSS_NONE, 8);
++#else
+ read_write_flags, GEGL_ABYSS_NONE);
++#endif
+
+ // Read out
+ gboolean completed = gegl_buffer_iterator_next(iterator);
+@@ -88,7 +92,11 @@ tile_request_start(MyPaintTiledSurface *tiled_surface, MyPaintTileRequest *reque
+ g_critical("Unable to get tile aligned access to GeglBuffer");
+ request->buffer = NULL;
+ } else {
++#if GEGL_MAJOR_VERSION == 0 && GEGL_MINOR_VERSION == 4 && GEGL_MICRO_VERSION >= 14
++ request->buffer = (uint16_t *)(iterator->items[0].data);
++#else
+ request->buffer = (uint16_t *)(iterator->data[0]);
++#endif
+ }
+
+ // So we can finish the iterator in tile_request_end()