summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:10:49 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:10:49 +0100
commit38f945d190be4e07b1613a42536b85b513658006 (patch)
treee7841aef6f537e12ac22ae631dea78bd5139ef14 /extra
parent44997e9d4fe44e6c7c4a55556d888ae1d9a94fc5 (diff)
parentc82f1064549c938d8d64dd434ceeff228f0fa4fb (diff)
downloadpackages-38f945d190be4e07b1613a42536b85b513658006.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'extra')
-rw-r--r--extra/conky/PKGBUILD8
-rw-r--r--extra/conky/fix-type-mismatch.patch13
-rw-r--r--extra/linux-pae/PKGBUILD6
-rw-r--r--extra/linux-pae/config4
4 files changed, 26 insertions, 5 deletions
diff --git a/extra/conky/PKGBUILD b/extra/conky/PKGBUILD
new file mode 100644
index 00000000..506fad26
--- /dev/null
+++ b/extra/conky/PKGBUILD
@@ -0,0 +1,8 @@
+#see https://github.com/brndnmtthws/conky/issues/759
+sha256sums+=('842a3377b1d4fcaff8ec409b68fe6b05a9faf500f29b4d8e21cec3b4cd5b7da2')
+source+=('fix-type-mismatch.patch')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/fix-type-mismatch.patch"
+}
diff --git a/extra/conky/fix-type-mismatch.patch b/extra/conky/fix-type-mismatch.patch
new file mode 100644
index 00000000..a84d05e2
--- /dev/null
+++ b/extra/conky/fix-type-mismatch.patch
@@ -0,0 +1,13 @@
+diff --git a/src/linux.cc b/src/linux.cc
+index 0a7d4331..09fa6c99 100644
+--- a/src/linux.cc
++++ b/src/linux.cc
+@@ -1169,7 +1169,7 @@ static int open_sysfs_sensor(const char *dir, const char *dev, const char *type,
+ fd = open(path, O_RDONLY);
+ if (fd < 0) {
+ /* if it fails, strip the /device from dev and attempt again */
+- size_t len_to_trunc = std::max(7UL, strnlen(buf, 255)) - 7;
++ size_t len_to_trunc = std::max((size_t)7UL, strnlen(buf, 255)) - 7;
+ buf[len_to_trunc] = 0;
+ snprintf(path, 255, "%s%s/%s%d_input", dir, dev, type, n);
+ fd = open(path, O_RDONLY);
diff --git a/extra/linux-pae/PKGBUILD b/extra/linux-pae/PKGBUILD
index 98cd61a9..2fc41268 100644
--- a/extra/linux-pae/PKGBUILD
+++ b/extra/linux-pae/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae # Build stock -ARCH kernel
-pkgver='4.20'
+pkgver='4.20.1'
_srcname=linux-${pkgver}
pkgrel='1'
arch=('i686')
@@ -24,9 +24,9 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('ad0823183522e743972382df0aa08fb5ae3077f662b125f1e599b0b2aaa12438'
+sha256sums=('45096f1ffbfbb4cdeef6eecfa6ca7eabbf534f04645fd0d849564a58ddd2198f'
'SKIP'
- 'bc31046541799e3d0a916894ca4fb7bba387f582a37216e98345c095f8f5ee43'
+ 'b5f3d1a14dce62f52c6cf4efb67751cc6080515b2c969912f724e280b9b78060'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
diff --git a/extra/linux-pae/config b/extra/linux-pae/config
index 9175b3c3..e09adaad 100644
--- a/extra/linux-pae/config
+++ b/extra/linux-pae/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.20.0-1 Kernel Configuration
+# Linux/x86 4.20.1-1 Kernel Configuration
#
#
@@ -7277,10 +7277,10 @@ CONFIG_TYPEC_MUX_PI3USB30532=m
# USB Type-C Alternate Mode drivers
#
CONFIG_TYPEC_DP_ALTMODE=m
+CONFIG_USB_ROLE_SWITCH=m
CONFIG_USB_ROLES_INTEL_XHCI=m
CONFIG_USB_LED_TRIG=y
CONFIG_USB_ULPI_BUS=m
-CONFIG_USB_ROLE_SWITCH=m
CONFIG_UWB=m
CONFIG_UWB_HWA=m
CONFIG_UWB_WHCI=m