summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-21 14:54:54 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-21 14:54:54 +0200
commit2c50b6a63327c6e6f0c0230a42c23ab2f47b8e11 (patch)
tree6034b7c6a40ce661b15cb283aa717b2fe82e7ca2 /extra
parent5c6660502b08f34f504ff4ca6deabe9fe5f81e34 (diff)
downloadpackages-2c50b6a63327c6e6f0c0230a42c23ab2f47b8e11.tar.xz
community/libgda: renamed from extra/libgda
Diffstat (limited to 'extra')
-rw-r--r--extra/libgda/PKGBUILD12
-rw-r--r--extra/libgda/java.patch36
2 files changed, 0 insertions, 48 deletions
diff --git a/extra/libgda/PKGBUILD b/extra/libgda/PKGBUILD
deleted file mode 100644
index 553e47f2..00000000
--- a/extra/libgda/PKGBUILD
+++ /dev/null
@@ -1,12 +0,0 @@
-# backported java probing patch for i386
-source+=('java.patch')
-sha256sums+=('e28ea88d49bcb91fa6907440a6785a508fb681c463188b3805509773f5d0fc22')
-
-eval "$(
- declare -f prepare | \
- sed '
- /autogen/ i \
- patch -Np1 -i "$srcdir/java.patch" \
- javac getsp.java
- '
-)"
diff --git a/extra/libgda/java.patch b/extra/libgda/java.patch
deleted file mode 100644
index 7f12c5ad..00000000
--- a/extra/libgda/java.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -u -r libgda-5.2.4/getsp.java libgda-5.2.4-java/getsp.java
---- libgda-5.2.4/getsp.java 2014-02-05 21:28:20.000000000 +0100
-+++ libgda-5.2.4-java/getsp.java 2015-06-14 20:27:35.770310228 +0200
-@@ -25,7 +25,7 @@
- while (i<=j) {
- if (i==j || lp.charAt(i)==ps) {
- String lib=lp.substring(k,i);
-- String suffix="/lib/amd64/server";
-+ String suffix="/lib/"+System.getProperty("os.arch")+"/server";
- k=i+1;
- if (lib.compareTo(".")!=0)
- r=(r==null)?(prefix+lib+suffix):(r+" "+prefix+lib+suffix);
-@@ -50,7 +50,7 @@
-
- if (r!=null) System.out.println(r);
- } else if (args[0].compareTo("-ldpath")==0) {
-- String lp1=System.getProperty("java.home")+"/lib/amd64/server";
-+ String lp1=System.getProperty("java.home")+"/lib/"+System.getProperty("os.arch")+"/server";
- String lp2=System.getProperty("java.library.path");
- System.out.println(lp1+":"+lp2);
- }
-diff -u -r libgda-5.2.4/m4/java.m4 libgda-5.2.4-java/m4/java.m4
---- libgda-5.2.4/m4/java.m4 2015-06-13 10:36:25.000000000 +0200
-+++ libgda-5.2.4-java/m4/java.m4 2015-06-14 20:16:59.865581930 +0200
-@@ -175,6 +175,11 @@
- JTYPE="Sun JRE 1.7"
- JFLAGS="-Xlint:unchecked -Xlint:deprecation"
- ;;
-+ JRE1.8.*)
-+ try_java=true
-+ JTYPE="Sun JRE 1.8"
-+ JFLAGS="-Xlint:unchecked -Xlint:deprecation"
-+ ;;
- JREgcj-4*)
- try_java=true
- JTYPE="GCJ"