summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-06-03 19:57:22 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-06-03 19:57:22 +0200
commit27d20eb584909ebc44e46d926a1193e498aff2c7 (patch)
tree871aaa2d9a6b1b23e74bbc165e2c12b653bf6e5c /extra
parentcd1ad69a718eba8e09463bab1dc604b74af3c4db (diff)
downloadpackages-27d20eb584909ebc44e46d926a1193e498aff2c7.tar.xz
extra/clutter: disabled wayland on i486 (due to cogl)
Diffstat (limited to 'extra')
-rw-r--r--extra/clutter/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/clutter/PKGBUILD b/extra/clutter/PKGBUILD
new file mode 100644
index 00000000..9f6d1a0e
--- /dev/null
+++ b/extra/clutter/PKGBUILD
@@ -0,0 +1,10 @@
+# we built cogl without waylang on i486, so disable it here too
+if [ "${CARCH}" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-wayland-compositor/--disable-wayland-compositor/
+ s/--enable-wayland-backend/--disable-wayland-backend/
+ '
+ )"
+fi