summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-08-31 09:09:27 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-08-31 09:09:27 +0200
commit16bc4268d13ded51c6819de5d5c267c3799c626a (patch)
treec8cbe4871277788f7243faf3e51987bbd8c66e7a /extra
parent9cc261c47e0d72b4ba748ff8103b6b80d0a63c79 (diff)
downloadpackages-16bc4268d13ded51c6819de5d5c267c3799c626a.tar.xz
extra/gst-plugins-good: removed superflous patch
Diffstat (limited to 'extra')
-rw-r--r--extra/gst-plugins-good/PKGBUILD9
-rw-r--r--extra/gst-plugins-good/gst-plugins-good-1.14.1-fix-elements-rtpstorage-BUG796429.patch97
2 files changed, 0 insertions, 106 deletions
diff --git a/extra/gst-plugins-good/PKGBUILD b/extra/gst-plugins-good/PKGBUILD
deleted file mode 100644
index 66e07bce..00000000
--- a/extra/gst-plugins-good/PKGBUILD
+++ /dev/null
@@ -1,9 +0,0 @@
-# fixed upstreams, see https://bugzilla.gnome.org/show_bug.cgi?id=796429
-source+=(gst-plugins-good-1.14.1-fix-elements-rtpstorage-BUG796429.patch)
-sha256sums+=('13fb05a15dcf9b3141e71fee6158ddcb59e5a60aba83cd47a58188e5ad93449a')
-eval "$(
- declare -f prepare | \
- sed '
- /cd /a patch -Np1 -i ${srcdir}/gst-plugins-good-1.14.1-fix-elements-rtpstorage-BUG796429.patch
- '
-)"
diff --git a/extra/gst-plugins-good/gst-plugins-good-1.14.1-fix-elements-rtpstorage-BUG796429.patch b/extra/gst-plugins-good/gst-plugins-good-1.14.1-fix-elements-rtpstorage-BUG796429.patch
deleted file mode 100644
index 69922c70..00000000
--- a/extra/gst-plugins-good/gst-plugins-good-1.14.1-fix-elements-rtpstorage-BUG796429.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-diff --git a/tests/check/elements/rtpstorage.c b/tests/check/elements/rtpstorage.c
-index 4a1d60f64..e80b2122b 100644
---- a/tests/check/elements/rtpstorage.c
-+++ b/tests/check/elements/rtpstorage.c
-@@ -98,16 +98,17 @@ GST_START_TEST (rtpstorage_resize)
- guint i, j;
- GstBuffer *bufin, *bufout, *bufs[10];
- GstHarness *h = gst_harness_new ("rtpstorage");
-+
- gst_harness_set_src_caps_str (h, "application/x-rtp");
-
-- g_object_set (h->element, "size-time", 0, NULL);
-+ g_object_set (h->element, "size-time", (guint64) 0, NULL);
- bufin = create_rtp_packet (96, 0xabe2b0b, 0x111111, 0);
- bufout = gst_harness_push_and_pull (h, bufin);
- fail_unless (bufin == bufout);
- fail_unless (gst_buffer_is_writable (bufout));
-
-- g_object_set (h->element, "size-time",
-- (G_N_ELEMENTS (bufs) - 1) * RTP_PACKET_DUR, NULL);
-+ g_object_set (h->element,
-+ "size-time", (guint64) (G_N_ELEMENTS (bufs) - 1) * RTP_PACKET_DUR, NULL);
-
- // Pushing 10 buffers all of them should have ref. count =2
- for (i = 0; i < G_N_ELEMENTS (bufs); ++i) {
-@@ -139,7 +140,7 @@ GST_START_TEST (rtpstorage_stop_redundant_packets)
- GstHarness *h = gst_harness_new ("rtpstorage");
- GstBuffer *bufinp;
-
-- g_object_set (h->element, "size-time", 2 * RTP_PACKET_DUR, NULL);
-+ g_object_set (h->element, "size-time", (guint64) 2 * RTP_PACKET_DUR, NULL);
- gst_harness_set_src_caps_str (h, "application/x-rtp");
-
- bufinp = create_rtp_packet (96, 0xabe2b0b, 0x111111, 0);
-@@ -159,7 +160,7 @@ GST_START_TEST (rtpstorage_unknown_ssrc)
- {
- GstBufferList *bufs_out;
- GstHarness *h = gst_harness_new ("rtpstorage");
-- g_object_set (h->element, "size-time", RTP_PACKET_DUR, NULL);
-+ g_object_set (h->element, "size-time", (guint64) RTP_PACKET_DUR, NULL);
- gst_harness_set_src_caps_str (h, "application/x-rtp");
-
- /* No packets has been pushed through yet */
-@@ -182,7 +183,7 @@ GST_START_TEST (rtpstorage_packet_not_lost)
- GstBuffer *buf;
- GstBufferList *bufs_out;
- GstHarness *h = gst_harness_new ("rtpstorage");
-- g_object_set (h->element, "size-time", 10 * RTP_PACKET_DUR, NULL);
-+ g_object_set (h->element, "size-time", (guint64) 10 * RTP_PACKET_DUR, NULL);
- gst_harness_set_src_caps_str (h, "application/x-rtp");
-
- /* Pushing through 2 frames + 2 FEC */
-@@ -212,7 +213,7 @@ GST_START_TEST (test_rtpstorage_put_recovered_packet)
- GstBuffer *bufs_in[4];
- GstBufferList *bufs_out;
- GstHarness *h = gst_harness_new ("rtpstorage");
-- g_object_set (h->element, "size-time", 10 * RTP_PACKET_DUR, NULL);
-+ g_object_set (h->element, "size-time", (guint64) 10 * RTP_PACKET_DUR, NULL);
- gst_harness_set_src_caps_str (h, "application/x-rtp");
-
- /* Pushing through 2 frames + 2 FEC
-@@ -331,7 +332,7 @@ _multiple_ssrcs_test (guint16 nth_to_loose,
- guint16 stream0_seq_start = 200;
- guint16 stream1_seq_start = 65529;
- GstHarness *h = gst_harness_new ("rtpstorage");
-- g_object_set (h->element, "size-time", 12 * RTP_PACKET_DUR, NULL);
-+ g_object_set (h->element, "size-time", (guint64) 12 * RTP_PACKET_DUR, NULL);
- gst_harness_set_src_caps_str (h, "application/x-rtp");
-
- _single_ssrc_test (h, 0x0abe2b0b, stream0_seq_start,
-@@ -453,8 +454,8 @@ GST_START_TEST (rtpstorage_stress)
- StressTestData test_data;
- guint seed, i, total, requested;
- GstHarness *h = gst_harness_new ("rtpstorage");
-- g_object_set (h->element, "size-time",
-- STRESS_TEST_STORAGE_DEPTH * RTP_PACKET_DUR, NULL);
-+ g_object_set (h->element,
-+ "size-time", (guint64) STRESS_TEST_STORAGE_DEPTH * RTP_PACKET_DUR, NULL);
-
- /* The stress test pushes buffers with STRESS_TEST_SSRCS different
- * ssrcs from one thread and requests packets for FEC recovery from
-diff --git a/tests/check/elements/rtpulpfec.c b/tests/check/elements/rtpulpfec.c
-index e0fa97262..57de5cd71 100644
---- a/tests/check/elements/rtpulpfec.c
-+++ b/tests/check/elements/rtpulpfec.c
-@@ -154,7 +154,8 @@ harness_rtpulpfecdec (guint32 ssrc, guint8 lost_pt, guint8 fec_pt)
- g_strdup_printf ("application/x-rtp,ssrc=(uint)%u,payload=(int)%u",
- ssrc, lost_pt);
-
-- gst_harness_set (h, "rtpstorage", "size-time", 200 * RTP_PACKET_DUR, NULL);
-+ gst_harness_set (h, "rtpstorage", "size-time", (guint64) 200 * RTP_PACKET_DUR,
-+ NULL);
- gst_harness_get (h, "rtpstorage", "internal-storage", &internal_storage,
- NULL);
- gst_harness_set (h, "rtpulpfecdec", "storage", internal_storage, "pt", fec_pt,
---
-