summaryrefslogtreecommitdiff
path: root/extra/x265
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:03:23 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:03:23 +0100
commitc2b2f00057bd52e54fcdc4ff92f8421e651ce815 (patch)
treee40e3db6f4c572f168da90e5b80127d5f29fa224 /extra/x265
parent7f1e3da67e8b6bbc45c85937d4938547f32076d6 (diff)
parent75b2223f9e8b10faaef8f4f819c142eac8dacb93 (diff)
downloadpackages-c2b2f00057bd52e54fcdc4ff92f8421e651ce815.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'extra/x265')
-rw-r--r--extra/x265/0003-detect512-is-needed-on-all-architectures.patch35
-rw-r--r--extra/x265/PKGBUILD9
2 files changed, 44 insertions, 0 deletions
diff --git a/extra/x265/0003-detect512-is-needed-on-all-architectures.patch b/extra/x265/0003-detect512-is-needed-on-all-architectures.patch
new file mode 100644
index 00000000..16aab240
--- /dev/null
+++ b/extra/x265/0003-detect512-is-needed-on-all-architectures.patch
@@ -0,0 +1,35 @@
+From: Adam Sampson <unknown@bitbucket>
+Date: Sun, 14 Oct 2018 14:04:18 +0200
+Subject: detect512 is needed on all architectures
+
+---
+ source/common/cpu.cpp | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/source/common/cpu.cpp b/source/common/cpu.cpp
+index 0681ff5..fa687da 100644
+--- a/source/common/cpu.cpp
++++ b/source/common/cpu.cpp
+@@ -110,6 +110,11 @@ const cpu_name_t cpu_names[] =
+ { "", 0 },
+ };
+
++bool detect512()
++{
++ return(enable512);
++}
++
+ #if X265_ARCH_X86
+
+ extern "C" {
+@@ -123,10 +128,6 @@ uint64_t PFX(cpu_xgetbv)(int xcr);
+ #pragma warning(disable: 4309) // truncation of constant value
+ #endif
+
+-bool detect512()
+-{
+- return(enable512);
+-}
+ uint32_t cpu_detect(bool benableavx512 )
+ {
+
diff --git a/extra/x265/PKGBUILD b/extra/x265/PKGBUILD
index 70b20b4c..0dc3dc58 100644
--- a/extra/x265/PKGBUILD
+++ b/extra/x265/PKGBUILD
@@ -6,3 +6,12 @@ eval "$(
s/cmake/cmake -DENABLE_ASSEMBLY=OFF/
'
)"
+# thanks, debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910963
+source+=('0003-detect512-is-needed-on-all-architectures.patch')
+sha256sum+=('+6baa25d11c81ad4ee49e9f2a367db4c770eb8cccf81f7bdaadb942621288a271')
+eval "$(
+ declare -f prepare | \
+ sed '
+ 3 a patch -p1 -i "$srcdir/0003-detect512-is-needed-on-all-architectures.patch"
+ '
+)"