summaryrefslogtreecommitdiff
path: root/extra/webkit2gtk
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-06-02 10:47:13 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-06-02 10:47:13 +0200
commitf2fd21e31bc4cb4fe73fccb7784624181cf2125e (patch)
tree293b31645e5f62e60e484b303c3fee42a02a726b /extra/webkit2gtk
parent65d72c2be5e3d72c7cae84b2862c09fbdf25eb17 (diff)
downloadpackages-f2fd21e31bc4cb4fe73fccb7784624181cf2125e.tar.xz
extra/webkit2gtk: redone no-SSE2 patch
Diffstat (limited to 'extra/webkit2gtk')
-rw-r--r--extra/webkit2gtk/PKGBUILD11
-rw-r--r--extra/webkit2gtk/webkitgtk-2.32.0-no-sse2.arch32.patch83
-rw-r--r--extra/webkit2gtk/webkitgtk-2.36.3-no-sse2.arch32.patch50
3 files changed, 55 insertions, 89 deletions
diff --git a/extra/webkit2gtk/PKGBUILD b/extra/webkit2gtk/PKGBUILD
index 6919b547..6e0af735 100644
--- a/extra/webkit2gtk/PKGBUILD
+++ b/extra/webkit2gtk/PKGBUILD
@@ -1,14 +1,13 @@
# disable SSE2 on 486 and 686
-source_i486+=('webkitgtk-2.32.0-no-sse2.arch32.patch')
-source_i686+=('webkitgtk-2.32.0-no-sse2.arch32.patch')
-sha256sums_i486+=('11f3d9cd6d36db290fd725f57530fb6ea398bb61fcf2575a77154d7009c1718a')
-sha256sums_i686+=('11f3d9cd6d36db290fd725f57530fb6ea398bb61fcf2575a77154d7009c1718a')
-
+source_i486+=('webkitgtk-2.36.3-no-sse2.arch32.patch')
+source_i686+=('webkitgtk-2.36.3-no-sse2.arch32.patch')
+sha256sums_i486+=('58a724b7f1092a9049186a3b8c61689c31558b6c2b587c827cec04219397adac')
+sha256sums_i686+=('58a724b7f1092a9049186a3b8c61689c31558b6c2b587c827cec04219397adac')
if [ "${CARCH}" != "pentium4" ]; then
eval "$(
declare -f prepare | \
sed '
- /cd.*/a for _p in \"$srcdir\"\/*.arch32.patch; do patch -p1 -i \"$_p\"; done
+ /cd.*/a patch -Rp1 -i "$srcdir"/webkitgtk-2.36.3-no-sse2.arch32.patch
'
)"
fi
diff --git a/extra/webkit2gtk/webkitgtk-2.32.0-no-sse2.arch32.patch b/extra/webkit2gtk/webkitgtk-2.32.0-no-sse2.arch32.patch
deleted file mode 100644
index 4d453aae..00000000
--- a/extra/webkit2gtk/webkitgtk-2.32.0-no-sse2.arch32.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-diff -rauN webkitgtk-2.32.0/Source/cmake/WebKitCompilerFlags.cmake webkitgtk-2.32.0-no-sse2-patch/Source/cmake/WebKitCompilerFlags.cmake
---- webkitgtk-2.32.0/Source/cmake/WebKitCompilerFlags.cmake 2021-03-25 14:27:32.000000000 +0100
-+++ webkitgtk-2.32.0-no-sse2-patch/Source/cmake/WebKitCompilerFlags.cmake 2021-05-08 17:00:53.952879632 +0200
-@@ -143,13 +143,13 @@
- endif ()
-
- # Force SSE2 fp on x86 builds.
-- if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
-- WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
-- include(DetectSSE2)
-- if (NOT SSE2_SUPPORT_FOUND)
-- message(FATAL_ERROR "SSE2 support is required to compile WebKit")
-- endif ()
-- endif ()
-+# if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
-+# WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
-+# include(DetectSSE2)
-+# if (NOT SSE2_SUPPORT_FOUND)
-+# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
-+# endif ()
-+# endif ()
- endif ()
-
- if (COMPILER_IS_GCC_OR_CLANG AND NOT MSVC)
-diff -rauN webkitgtk-2.32.0/Source/ThirdParty/ANGLE/src/common/platform.h webkitgtk-2.32.0-no-sse2-patch/Source/ThirdParty/ANGLE/src/common/platform.h
---- webkitgtk-2.32.0/Source/ThirdParty/ANGLE/src/common/platform.h 2021-02-26 10:57:06.000000000 +0100
-+++ webkitgtk-2.32.0-no-sse2-patch/Source/ThirdParty/ANGLE/src/common/platform.h 2021-05-08 17:02:05.056394762 +0200
-@@ -90,8 +90,8 @@
- # include <intrin.h>
- # define ANGLE_USE_SSE
- #elif defined(__GNUC__) && (defined(__x86_64__) || defined(__i386__))
--# include <x86intrin.h>
--# define ANGLE_USE_SSE
-+//# include <x86intrin.h>
-+//# define ANGLE_USE_SSE
- #endif
-
- // Mips and arm devices need to include stddef for size_t.
-diff -rauN webkitgtk-2.32.0/Source/WebCore/platform/audio/SincResampler.cpp webkitgtk-2.32.0-no-sse2-patch/Source/WebCore/platform/audio/SincResampler.cpp
---- webkitgtk-2.32.0/Source/WebCore/platform/audio/SincResampler.cpp 2021-02-26 10:57:13.000000000 +0100
-+++ webkitgtk-2.32.0-no-sse2-patch/Source/WebCore/platform/audio/SincResampler.cpp 2021-05-08 17:12:14.678638777 +0200
-@@ -39,6 +39,7 @@
- #if USE(ACCELERATE)
- #include <Accelerate/Accelerate.h>
- #elif CPU(X86_SSE2)
-+#error No SSE2
- #include <xmmintrin.h>
- #elif HAVE(ARM_NEON_INTRINSICS)
- #include <arm_neon.h>
-diff -rauN webkitgtk-2.32.0/Source/WebCore/platform/audio/VectorMath.cpp webkitgtk-2.32.0-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp
---- webkitgtk-2.32.0/Source/WebCore/platform/audio/VectorMath.cpp 2021-02-26 10:57:13.000000000 +0100
-+++ webkitgtk-2.32.0-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp 2021-05-08 17:12:40.725409625 +0200
-@@ -35,6 +35,7 @@
- #endif
-
- #if CPU(X86_SSE2)
-+#error No SSE2
- #include <emmintrin.h>
- #endif
-
-diff -rauN webkitgtk-2.32.0/Source/WTF/wtf/PlatformCPU.h webkitgtk-2.32.0-no-sse2-patch/Source/WTF/wtf/PlatformCPU.h
---- webkitgtk-2.32.0/Source/WTF/wtf/PlatformCPU.h 2021-02-26 10:57:08.000000000 +0100
-+++ webkitgtk-2.32.0-no-sse2-patch/Source/WTF/wtf/PlatformCPU.h 2021-05-08 17:13:21.592239207 +0200
-@@ -99,7 +99,7 @@
- #define WTF_CPU_KNOWN 1
-
- #if defined(__SSE2__) || (defined(_M_IX86_FP) && _M_IX86_FP >= 2)
--#define WTF_CPU_X86_SSE2 1
-+/* #define WTF_CPU_X86_SSE2 1 */
- #endif
-
- #endif
-diff -rauN webkitgtk-2.32.0/Source/WTF/wtf/text/ASCIIFastPath.h webkitgtk-2.32.0-no-sse2-patch/Source/WTF/wtf/text/ASCIIFastPath.h
---- webkitgtk-2.32.0/Source/WTF/wtf/text/ASCIIFastPath.h 2021-02-26 10:57:08.000000000 +0100
-+++ webkitgtk-2.32.0-no-sse2-patch/Source/WTF/wtf/text/ASCIIFastPath.h 2021-05-08 17:13:42.528989083 +0200
-@@ -27,6 +27,7 @@
- #include <wtf/text/LChar.h>
-
- #if CPU(X86_SSE2)
-+#error No SSE2
- #include <emmintrin.h>
- #endif
-
diff --git a/extra/webkit2gtk/webkitgtk-2.36.3-no-sse2.arch32.patch b/extra/webkit2gtk/webkitgtk-2.36.3-no-sse2.arch32.patch
new file mode 100644
index 00000000..63a098a7
--- /dev/null
+++ b/extra/webkit2gtk/webkitgtk-2.36.3-no-sse2.arch32.patch
@@ -0,0 +1,50 @@
+diff -rauN webkitgtk-2.36.3/Source/cmake/WebKitCompilerFlags.cmake webkitgtk-2.36.3-no-sse2-patch/Source/cmake/WebKitCompilerFlags.cmake
+--- webkitgtk-2.36.3/Source/cmake/WebKitCompilerFlags.cmake 2022-06-02 08:44:07.302049344 +0200
++++ webkitgtk-2.36.3-no-sse2-patch/Source/cmake/WebKitCompilerFlags.cmake 2022-06-02 08:32:46.169362098 +0200
+@@ -163,13 +163,13 @@
+ endif ()
+
+ # Force SSE2 fp on x86 builds.
+-# if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
+-# WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
+-# include(DetectSSE2)
+-# if (NOT SSE2_SUPPORT_FOUND)
+-# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
+-# endif ()
+-# endif ()
++ if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
++ WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
++ include(DetectSSE2)
++ if (NOT SSE2_SUPPORT_FOUND)
++ message(FATAL_ERROR "SSE2 support is required to compile WebKit")
++ endif ()
++ endif ()
+
+ # Makes builds faster. The GCC manual warns about the possibility that the assembler being
+ # used may not support input from a pipe, but in practice the toolchains we support all do.
+diff -rauN webkitgtk-2.36.3/Source/ThirdParty/ANGLE/src/common/platform.h webkitgtk-2.36.3-no-sse2-patch/Source/ThirdParty/ANGLE/src/common/platform.h
+--- webkitgtk-2.36.3/Source/ThirdParty/ANGLE/src/common/platform.h 2022-06-02 08:45:17.042348743 +0200
++++ webkitgtk-2.36.3-no-sse2-patch/Source/ThirdParty/ANGLE/src/common/platform.h 2022-06-02 08:32:46.189362180 +0200
+@@ -97,8 +97,8 @@
+ # include <intrin.h>
+ # define ANGLE_USE_SSE
+ #elif defined(__GNUC__) && (defined(__x86_64__) || defined(__i386__))
+-//# include <x86intrin.h>
+-//# define ANGLE_USE_SSE
++# include <x86intrin.h>
++# define ANGLE_USE_SSE
+ #endif
+
+ // Mips and arm devices need to include stddef for size_t.
+diff -rauN webkitgtk-2.36.3/Source/WTF/wtf/PlatformCPU.h webkitgtk-2.36.3-no-sse2-patch/Source/WTF/wtf/PlatformCPU.h
+--- webkitgtk-2.36.3/Source/WTF/wtf/PlatformCPU.h 2022-06-02 08:46:55.912771827 +0200
++++ webkitgtk-2.36.3-no-sse2-patch/Source/WTF/wtf/PlatformCPU.h 2022-06-02 08:32:45.789360661 +0200
+@@ -99,7 +99,7 @@
+ #define WTF_CPU_KNOWN 1
+
+ #if defined(__SSE2__) || (defined(_M_IX86_FP) && _M_IX86_FP >= 2)
+-/* #define WTF_CPU_X86_SSE2 1 */
++#define WTF_CPU_X86_SSE2 1
+ #endif
+
+ #endif